What Is Your Grade? (sort)

点击打开链接


“Point, point, life of student!” 
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course. 
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50. 
Note, only 1 student will get the score 95 when 3 students have solved 4 problems. 
I wish you all can pass the exam! 
Come on! 
Input
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p. 
A test case starting with a negative integer terminates the input and this test case should not to be processed. 
Output
Output the scores of N students in N lines for each case, and there is a blank line after each case. 
Sample Input
4
5 06:30:17
4 07:31:27
4 08:12:12
4 05:23:13
1
5 06:30:17
-1
Sample Output
100
90
90
95

100

题意:如果做出五道题,给100分,其余的是前n/2个人给(5+x)分数,以此类推。

题解:sort的应用,利用下标进行标记,进行选择排序即可。

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;

struct P{
	int num;
	int time;
	int id;
	int score;
}p[110];

bool cmp(P a,P b){
	if(a.num!=b.num)
	return a.num>b.num;
	else
	return a.time<b.time;
}

bool cmp1(P a,P b){
	return a.id<b.id;
}

int main(){
	int n;
	while(cin>>n&&n>0){
		int flag1,flag2,flag3,flag4;
		flag1=flag2=flag3=flag4=0;
		for(int i=0;i<n;i++){
			int h,m,s;
			cin>>p[i].num; 
			if(p[i].num==4)
			flag1++;
			if(p[i].num==3)
			flag2++;
			if(p[i].num==2)
			flag3++;
			if(p[i].num==1)
			flag4++;
			scanf("%d:%d:%d",&h,&m,&s);
			p[i].time = h*3600 + m*60 + s;
			p[i].id=i;
		}
		sort(p,p+n,cmp);
		flag1/=2;flag2/=2;flag3/=2;flag4/=2;
		for(int i=0;i<n;i++){
			if(p[i].num==5)
			p[i].score=100;
			else if(p[i].num==4){
				if(flag1){
					p[i].score=95;
					flag1--;
				}
				else
				p[i].score=90;
			}
			else if(p[i].num==3){
				if(flag2){
					p[i].score=85;
					flag2--;
				} 
				else
				p[i].score=80;
			}
			else if(p[i].num==2){
				if(flag3){
					p[i].score=75;
					flag3--;					
				}
				else
				p[i].score=70;
			}	
			else if(p[i].num==1){
				if(flag4){
					p[i].score=65;
					flag4--;
				}				
				else
				p[i].score=60;
			}
			else
			p[i].score=50;					
		}
		sort(p,p+n,cmp1);
		for(int i=0;i<n;i++)
		cout<<p[i].score<<endl;
		cout<<endl;
	}
	
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值