【POJ 2356】Find a multiple(抽屉原理-好题)



点击打开题目


Find a multiple
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8263 Accepted: 3592 Special Judge

Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order. 

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2
2
3

Source


题意:第一行是数字n第二行是数组n的长度,接下来是数组元素,求在数组元素中存在连续的元素之和是n的倍数,输出元素个数和每个元素的值

题解:利用前缀和抽屉原理,本题一定有解。

证:数字n,有n个元素的数组,可以得到n个前缀和,每个前缀和对n求余则 必定在【1~n-1】内,由抽屉原理,则至少有两个前缀和对n的余数相同,假 设为c,v;

则,能整除n的数字即为 v-c 之间的数字,输出其对应下标即可



代码:


#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;

int a[10010];
int mod[10010];
int sum[10010];

int main(){
	int n;
	while(cin>>n){
		memset(a,0,sizeof(a));//存元素个数
		memset(mod,0,sizeof(mod));//存余数
		memset(sum,0,sizeof(sum));//存前缀和
		for(int i=1;i<=n;i++)
			cin>>a[i];
		for(int i=1;i<=n;i++){
			sum[i]=sum[i-1]+a[i];
			if(sum[i]%n==0){
				cout<<i<<endl;
				for(int j=1;j<=i;j++){
					cout<<a[j]<<endl;
				}
				break;
			}
			else if(mod[sum[i]%n]!=0){
				cout<<i-mod[sum[i]%n]<<endl;
				for(int j=mod[sum[i]%n]+1;j<=i;j++)
				cout<<a[j]<<endl;
				break;
			}
			mod[sum[i]%n]=i;//记录该前缀和的余数是否出现过
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值