抽屉原理——poj2356 Find a multiple

Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order.

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

Sample Output

题目意思:给定n个自然数(n<=10000),这些数可能相等,从中选择若干个数,使得它们的和为n的倍数,并输出这些数。

解题思路:对输入的前n项求和,如果前k项和已经是n的倍数,那么直接输出前k项;如果不存在,那么这sum[1]到sum[n]对n取余,对余数用抽屉原理,余数共有1~n-1   n-1种情况,而现在有n个数,所以一定存在两项余数相等,那么这两项中间和就是n的倍数。

#include<iostream>
#include<cstring>
using namespace std;
int a[10005];
int sum[10005];//存放前a[n]项和;
int used[10005];//数组下标为余数,存放的数据为对应的sum的下标


int main(){
	memset ( sum, 0 , sizeof ( sum ) ) ;
	memset ( used , 0 , sizeof ( used ) ) ;
	int i,j,n,s=0;//n为输入的总数,s为前n项和
	cin>>n;
	for(i=1;i<=n;i++){
		cin>>a[i];
		s+=a[i];
		sum[i]=s;
		if(sum[i]%n==0){    //当前n项和已经是n的倍数时,直接输出这些数。
			cout<<i<<endl;
			for(j=1;j<=i;j++){
				cout<<a[j]<<endl;
			}
			break;
		}
		if(used[sum[i]%n]!=0){    //如果这个和对n的余数已经存在,那么就输出这两个和之间的数。
			cout<<i-used[sum[i]%n]<<endl;
			for ( j = used[sum [i] % n]+1 ; j <= i ; j ++ )
                            cout<<a[j]<<endl;
                        break;
		}		
		used[sum[i]%n]=i;	
	}
	
	
	
	
	return 0;
} 


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值