Description
给定一个整数m(50<m<20000),找出小于m的最大的10个素数。
Input
输入在一行中给出一个正整数m(50<m<20000)。
Output
在一行中按递减顺序输出10个满足条件的素数,每个素数输出占6列。没有其它任何附加格式和字符。
Sample Input 1
229
Sample Output 1
227 223 211 199 197 193 191 181 179 173
Source
PTA
Code
#include<stdio.h>
int sushu(int n)
{
int i;
for( i=2; i<n; i++)
{
if(n%i==0)
break;
}
if(i==n)
return 1;
else
return 0;
}
int main()
{
int m,count=0;
scanf("%d",&m);
for(int i=m-1; i>0; i--)
{
if(sushu(i))
{
printf("%6d",i);
count++;
}
if(count==10)
break;
}
return 0;
}