顺序表操作(数据结构)

这题我着实弄了很久,一直找不到一个小小的错误,虽然简单,不过代码的严谨性我还差很远的感觉。

函数接口定义:

List MakeEmpty(); 
Position Find( List L, ElementType X );
bool Insert( List L, ElementType X, Position P );
bool Delete( List L, Position P );

其中List结构定义如下:

typedef int Position;
typedef struct LNode *List;
struct LNode {
    ElementType Data[MAXSIZE];
    Position Last; /* 保存线性表中最后一个元素的位置 */
};

各个操作函数的定义为:

List MakeEmpty():创建并返回一个空的线性表;

Position Find( List L, ElementType X ):返回线性表中X的位置。若找不到则返回ERROR;

bool Insert( List L, ElementType X, Position P ):将X插入在位置P并返回true。若空间已满,则打印“FULL”并返回false;如果参数P指向非法位置,则打印“ILLEGAL POSITION”并返回false;

bool Delete( List L, Position P ):将位置P的元素删除并返回true。若参数P指向非法位置,则打印“POSITION P EMPTY”(其中P是参数值)并返回false。

输入样例:

6
1 2 3 4 5 6
3
6 5 1
2
-1 6

输出样例:

FULL Insertion Error: 6 is not in.
Finding Error: 6 is not in.
5 is at position 0.
1 is at position 4.
POSITION -1 EMPTY Deletion Error.
FULL Insertion Error: 0 is not in.
POSITION 6 EMPTY Deletion Error.
FULL Insertion Error: 0 is not in.

#include <stdio.h>
#include <stdlib.h>

#define MAXSIZE 5
#define ERROR -1
//typedef enum {false, true} bool;
typedef int ElementType;
typedef int Position;
typedef struct LNode *List;
struct LNode {
    ElementType Data[MAXSIZE];
    Position Last; /* 保存线性表中最后一个元素的位置 */
};

List MakeEmpty(); 
Position Find( List L, ElementType X );
bool Insert( List L, ElementType X, Position P );
bool Delete( List L, Position P );

int main()
{
    List L;
    ElementType X;
    Position P;
    int N;

    L = MakeEmpty();
    scanf("%d", &N);
    while ( N-- ) {
        scanf("%d", &X);
        if ( Insert(L, X, 0)==false )
            printf(" Insertion Error: %d is not in.\n", X);
    }
    scanf("%d", &N);
    while ( N-- ) {
        scanf("%d", &X);
        P = Find(L, X);
        if ( P == ERROR )
            printf("Finding Error: %d is not in.\n", X);
        else
            printf("%d is at position %d.\n", X, P);
    }
    scanf("%d", &N);
    while ( N-- ) {
        scanf("%d", &P);
        if ( Delete(L, P)==false )
            printf(" Deletion Error.\n");
        if ( Insert(L, 0, P)==false )
            printf(" Insertion Error: 0 is not in.\n");
    }
    return 0;
}

/* 你的代码将被嵌在这里 */

在这里感觉这题本来貌似没什么,不过细节主要有几个,一个是L->Last为了防止超过MAXSIZE需要不断加加,就是插入那段,其实插入也包括了创建行新的顺序表的功能,另一个就是大家要注意这个题目的要求,他是要求数据倒着插入,也就是数据要全部插入第一个,那么原有的数据就都要往后挪了,也就有了 for( i=L->Last; i>P; i-- )  L->Data[i] = L->Data[i-1]; 那么整个实现的代码就如下所示:

bool Insert( List L, ElementType X, Position P )
{
    if( !L )
    return false;
    
    if( L->Last == MAXSIZE)
    {
    printf("FULL");
    return false;
    } 
    
    if( P<0 || P>L->Last)
    {
    printf("ILLEGAL POSITION");
    return false;
    }  
    Position i;
    
    for( i=L->Last; i>P; i-- )
    L->Data[i] = L->Data[i-1]; 
    L->Data[P] = X; //开始时因为0不大于0所以直接跳出循环在这里给第一个赋值X; 
    L->Last++;  
    return true; 
}

上述的代码用L->Last++的方式计算,所以函数的返回条件就要注意到是大于等于还是大于,还有就是要先计算是否大于MAXSZIE这件事,在删除的这段函数,我忘了每次删除就应该让L->Last减少,导致第二个测试点一直错误,调试了很久才解决。

bool Delete( List L, Position P )
{
Position i = 0;
if(!L)
return false;
if( P >= L->Last || P<0 )
    {
    printf("POSITION %d EMPTY", P);
    return false;
    }

    L->Last--;//在这里我已开始是直接在for循环直接Last-1;所以导致错误

for( i=P; i<=L->Last; i++)
{
L->Data[i] = L->Data[i+1];
}
return true;

}

#include <stdio.h>
#include <stdlib.h>

#define MAXSIZE 5
#define ERROR -1
//typedef enum {false, true} bool;
typedef int ElementType;
typedef int Position;
typedef struct LNode *List;
struct LNode {
    ElementType Data[MAXSIZE];
    Position Last; /* 保存线性表中最后一个元素的位置 */
};

List MakeEmpty(); 
Position Find( List L, ElementType X );
bool Insert( List L, ElementType X, Position P );
bool Delete( List L, Position P );

int main()
{
    List L;
    ElementType X;
    Position P;
    int N;

    L = MakeEmpty();
    scanf("%d", &N);
    while ( N-- ) {
        scanf("%d", &X);
        if ( Insert(L, X, 0)==false )
            printf(" Insertion Error: %d is not in.\n", X);
    }
    scanf("%d", &N);
    while ( N-- ) {
        scanf("%d", &X);
        P = Find(L, X);
        if ( P == ERROR )
            printf("Finding Error: %d is not in.\n", X);
        else
            printf("%d is at position %d.\n", X, P);
    }
    scanf("%d", &N);
    while ( N-- ) {
        scanf("%d", &P);
        if ( Delete(L, P)==false )
            printf(" Deletion Error.\n");
        if ( Insert(L, 0, P)==false )
            printf(" Insertion Error: 0 is not in.\n");
    }
    return 0;
}

/* 你的代码将被嵌在这里 */
List MakeEmpty()
{
	List L = (List)malloc(sizeof(struct LNode));
	L->Last = 0;
	return L;
}

Position Find( List L, ElementType X )
{
	if(!L)
	return ERROR;
	Position i=0;
	while( i<L->Last )
	{
	if(L->Data[i]==X)
	return i;
	i++;
	}	
	return ERROR;
}

bool Insert( List L, ElementType X, Position P )
{
    if( !L )
    return false;
    
    if( L->Last == MAXSIZE)
    {
    printf("FULL");
    return false;
    } 
    
    if( P<0 || P>L->Last)
    {
    printf("ILLEGAL POSITION");
    return false;
    }  
    Position i;
    
    for( i=L->Last; i>P; i-- )
    L->Data[i] = L->Data[i-1]; 
    L->Data[P] = X; //开始时因为0不大于0所以直接跳出循环在这里给第一个赋值X; 
    L->Last++;  
    return true; 
}

bool Delete( List L, Position P )
{
	Position i = 0;
	if(!L)
	return false;
	if( P >= L->Last || P<0 )
    {
    printf("POSITION %d EMPTY", P);
    return false;
    }
    L->Last--;
	for( i=P; i<=L->Last; i++)
	{
		L->Data[i] = L->Data[i+1];
	}
	return true;
}
在里面的第六行//typedef enum {false, true} bool;需要注释掉,至于原因嘛,布吉岛,毕竟以前做题都是直接把枚举注释掉才能正常运作的。。emmmmmm, 没办法。


编译器:DEV C++

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值