hdu 1075

Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 

Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 

Output
In this problem, you have to output the translation of the history book.
 

Sample Input
  
  
START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
 

Sample Output
 
 
hello, i'm from mars. i like earth!


题意是给你几行字符串,一行有两个字符串,通过第二个字符串可以查询到第一个字符串,要你翻译给出的段落,其中不在字典中的字符串以及其他标点符号不用翻译。

用map来写这道题很好写

代码:

 

 #include<bits/stdc++.h>
using namespace std;
map<string,string> dic;
map<char,int> flag;
string s,s2,s3;
char a[3005];
char b[15];
void init(){
      int i;
      char c='a';
      flag[c]=1;
      for(i=1;i<=25;i++)flag[c+i]=1;
      return;
}
int main(){
    ios::sync_with_stdio(false);
    int i,j,k,kk,len;
    init();
   // cout<<flag[',']<<endl;
    gets(a);
    while(1){
        gets(a);
        len=strlen(a);
        if(a[0]=='E')break;
        for(i=0,j=0;;i++)
        if(a[i]==' ')break;
        else b[j++]=a[i];
        b[j]='\0';
        s2=b;
        i++;
        for(j=0;i<len;i++)b[j++]=a[i];
        b[j]='\0';
        s3=b;
        dic[s3]=s2;
        //cout<<s3<<" "<<s2<<endl;
    }
   // cout<<dic["fiwo"]<<endl;
   gets(a);
    while(1){
      gets(a);
  //    cout<<a<<endl;
      if(strcmp(a,"END")==0)break;
      len=strlen(a);
      j=0;
      for(i=0;i<len;i++){
           if(flag[a[i]])continue;
           //cout<<i<<endl;
           for(k=j,kk=0;k<=i-1;k++)b[kk++]=a[k];
           b[kk]='\0';
           s=b;
          // cout<<b<<kk<<dic[s]<<endl;
           if(dic[s]!="\0")cout<<dic[s];
           else {for(k=j;k<=i-1;k++)cout<<a[k];}
           cout<<a[i];
           j=i+1;
      }
      cout<<endl;
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值