hdu-1075-What Are You Talking About

                          What Are You Talking About

                                         Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
                                                                 Total Submission(s): 10456    Accepted Submission(s): 3331


Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 

Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 

Output
In this problem, you have to output the translation of the history book.
 

Sample Input
  
  
START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
 

Sample Output
  
  
hello, i'm from mars. i like earth!
Hint
Huge input, scanf is recommended.
 

Author
Ignatius.L
 
 
import java.util.HashMap;
import java.util.Scanner;//1075-hdu-What Are You Talking About

public  class Main {//8902301 2013-08-11 10:04:03 Accepted 1075 3203MS 67712K 1378 B Java 1983210400 
	public static void main(String[] args) {
		//BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
	
		Scanner scan=new Scanner(System.in);  
		  String a = scan.next();//START
          HashMap<String,String> map = new HashMap<String,String>();
		   while(!( a = scan.next()).equals("END")){
			     String b =scan.next();
			     map.put(b, a);//不可写反
				  
		   }
		   a=scan.next();//START
		   String c;
		     int Y=0;
		   while(!(c=scan.nextLine()).equals("END")){
			    
			   int clen = c.length();
			    c=c+"#";//需加一个探知下一个字符
			     int count=-1;
			    for(int i=0;i<clen;i++){	    	
			    	
			    	char ci=c.charAt(i);
			    	char cc = c.charAt(i+1);//探知下一位,却不输出cc	
			    	 if(!(ci>= 'a' && ci<= 'z')){//不为小写字母
				    		count=i;
				    	
				    		System.out.print(ci);//注意if,else的顺序
				    		continue;
				    	 }
			    	 else {
			    	       if(!(cc>= 'a' && cc<= 'z'))
			    		   {
			                 String s=c.substring(count+1, i+1);//注意subString
			    			 if(map.containsKey(s))
			    				  System.out.print(map.get(s));	    			
			    		     else
			    				  System.out.print(s);	   
			    	      }
			    	     // continue; 
			    	  }
			    		
			    }
			    if(Y>0)
			    System.out.println();//总是PE,最终找到解决方案了
			    Y++;
		   } 
		  
	}
}

他人的:
import java.util.HashMap;  
import java.util.Scanner;  
  
public class Main{//8902241 2013-08-11 09:58:35 Accepted 1075 2953MS 67700K 1532 B Java 
    public static void main(String[] args) {  
        Scanner input=new Scanner(System.in);  
        String s=input.next();  
        HashMap<String,String> map=new HashMap<String, String>();  
        while(!(s=input.next()).equals("END")){  
            String str=input.next();  
            map.put(str, s);  
        }  
        s=input.next();  
        String sss=input.nextLine();  
        while(true){  
            String s2=input.nextLine();  
            if(s2.equals("END"))  
                break;  
            boolean ok=true;  
            int x=0;  
            for(int i=0;i<s2.length();i++){  
                char a=s2.charAt(i);  
                if(a>='a'&&a<='z'){  
                    if(ok){  
                        x=i;  
                        ok=false;  
                    }  
                }  
                else{  
                    if(ok==false){  
                        String s1=s2.substring(x,i);  
                        if(map.get(s1)!=null){  
                            System.out.print(map.get(s1));  
                        }  
                        else  
                            System.out.print(s1);  
                    }  
                    System.out.print(a);  
                    ok=true;  
                }  
            }  
            System.out.println();  
        }  
          
    }  
}  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值