HDU 3501 Calculation 2

HDU 3501 Calculation 2

题目链接

  • Problem Description
  • Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.

  • Input

    For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
    
  • Ouput

    For each test case, you should print the sum module 1000000007 in a line.
    
  • Sample Input

    3
    4
    0
    
  • Sample Output

    0
    2
    
  • 题解

        欧拉公式的引伸:小于或等于n的数中,与n互质的数的总和为:φ(x) * x / 2。(n>1)
    所以:res = n*(n-1)/2-n - phi[x]*x/2
    
  • 代码如下:
#include <iostream>

using namespace std;
typedef long long ll;
const int mod=1000000007;

int euler1(int n)
{
    int rea=n,sum=0;
    for(int i=2; i*i<=n; i++)
        if(n%i==0)
        {
            rea=rea-rea/i;
            do
                n/=i;
            while(n%i==0);
        }
    if(n>1)
        rea=rea-rea/n;
    return rea;
}
int main()
{
    ll n;
    while(cin>>n,n){
        ll s=(ll(n*(n-1)/2)%mod-ll(n*euler1(n)/2)%mod+mod)%mod;
        cout<<s<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值