HDU6440-Dream-CCPC2018网络赛

HDU:http://acm.hdu.edu.cn/showproblem.php?pid=6440

Problem Description
Freshmen frequently make an error in computing the power of a sum of real numbers, which usually origins from an incorrect equation (m+n)p=mp+np, where m,n,p are real numbers. Let's call it ``Beginner's Dream''.

For instance, (1+4)2=52=25, but 12+42=17≠25. Moreover, 9+16−−−−−√=25−−√=5, which does not equal 3+4=7. 

Fortunately, in some cases when p is a prime, the identity
(m+n)p=mp+np

holds true for every pair of non-negative integers m,n which are less than p, with appropriate definitions of addition and multiplication.

You are required to redefine the rules of addition and multiplication so as to make the beginner's dream realized.

Specifically, you need to create your custom addition and multiplication, so that when making calculation with your rules the equation (m+n)p=mp+np is a valid identity for all non-negative integers m,n less than p. Power is defined as
ap={1,ap−1⋅a,p=0p>0


Obviously there exists an extremely simple solution that makes all operation just produce zero. So an extra constraint should be satisfied that there exists an integer q(0<q<p) to make the set {qk|0<k<p,k∈Z} equal to {k|0<k<p,k∈Z}. What's more, the set of non-negative integers less than p ought to be closed under the operation of your definitions.

Hint

Hint for sample input and output:
From the table we get 0+1=1, and thus (0+1)2=12=1⋅1=1. On the other hand, 02=0⋅0=0, 12=1⋅1=1, 02+12=0+1=1.
They are the same.
 

Input
The first line of the input contains an positive integer T(T≤30) indicating the number of test cases.

For every case, there is only one line contains an integer p(p<210), described in the problem description above. p is guranteed to be a prime.
 

Output
For each test case, you should print 2p lines of p integers.

The j-th(1≤j≤p) integer of i-th(1≤i≤p) line denotes the value of (i−1)+(j−1). The j-th(1≤j≤p) integer of (p+i)-th(1≤i≤p) line denotes the value of (i−1)⋅(j−1).
 

Sample Input
1
2
 

Sample Output
0 1
1 0
0 0
0 1
 

Source
2018中国大学生程序设计竞赛 - 网络选拔赛

题目描述超长,所以我们提取关键信息。

在output里面说了详细输出规则

The j-th(1≤j≤p) integer of i-th(1≤i≤p) line denotes the value of (i−1)+(j−1).

The j-th(1≤j≤p) integer of (p+i)-th(1≤i≤p) line denotes the value of (i−1)⋅(j−1).

所以...我们直接写两个双层for循环,打印内容即可。

但有注意的几点:

1.在判断换行和空格的时候,不要写在printf后面,应该写在printf里面,避免超时!即:printf("%d%c",(i+j-2)%p,j==p?'\n':' ');

2.题意---叫我们自己定义加减法,我们便定义如下:

注意要取模(根据测试数据推断!)

3.不用cin,cout。用scanf,printf,这样输入输出更快。

代码:

#include <iostream>
using namespace std;

typedef long long LL;
int main(){
	int T,p;
	scanf("%d",&T);
	while(T--){
		scanf("%d",&p);
		for(int i=1;i<=p;i++){
			for(int j=1;j<=p;j++){
				printf("%d%c",(i+j-2)%p,j==p?'\n':' ');
				//此处将判断移入到上一行的printf中,这样可避免超时... 
			}
		} 
		for(int i=1;i<=p;i++){
			for(int j=1;j<=p;j++){
				printf("%d%c", ((i-1)*(j-1))%p ,j==p?'\n':' ');
				
			}
		} 
	}
	return 0;
}
//getchar函数是字符输入函数,putchar代表是单个字符输出函数

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值