[HDU]1150 Machine Schedule 二分图 + 最小点覆盖

Machine Schedule

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8656    Accepted Submission(s): 4347


Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 
 

Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.
 

Output
The output should be one integer per line, which means the minimal times of restarting machine.
 

Sample Input
  
  
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8 3 3 9 4 3 0
 

Sample Output
  
  
3
 

Source
    建二分图, 将a的模式放在左边, b的模式放在右边.
    如果一个任务能被a的x完成和b的y完成, 就把x向y建边.
    那么现在每条边就是一个任务, 要完成所有任务可以理解为覆盖所有边, 因为切换一个模式就重启一次, 所以就要选少的点(即模式). 那么相当于就是要求用最少的点覆盖完所有的边. 那么这就是最小点覆盖. 最小点覆盖 == 最大匹配. 二分图建起来跑匈牙利即可.
    本来模式是0, 所以一开始模式用0就能完成的任务就不用管. 这点细节要注意.
#include<stdio.h>
#include<bitset>
#include<cstring>
#define clear(a) memset(a, 0, sizeof(a))
using namespace std;
const int maxn = 2005;
bitset<maxn> vis;
int h[maxn], match[maxn], num, ans, n, m, k;
struct edge{ int nxt, v;}e[maxn * maxn];
inline void add(int u, int v){
	e[++num].v = v, e[num].nxt = h[u], h[u] = num;
}
bool find(int u){
	for(int i  = h[u]; i; i = e[i].nxt){
		int v = e[i].v;
		if(!vis[v]){
			vis[v] = 1;
			if(!match[v] || find(match[v]))
				return match[v] = u;
		}
	}
	return false;
}
int main(){
	while(~scanf("%d", &n), n){
		num = ans = 0;
		clear(h), clear(match);
		scanf("%d%d", &m, &k);
		for(int i = 1; i <= k; ++i){
			int a, b, c;
			scanf("%d%d%d", &a, &b, &c);
			if(b == 0 || c == 0) continue;
			add(b, c + n);
		}
		for(int i = 1; i <= n; ++i){
			if(find(i)) ++ans;
			vis = 0;
		}
		printf("%d\n", ans);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值