hdu 1150 Machine Schedule(最小顶点覆盖)

20 篇文章 0 订阅

Machine Schedule

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4288    Accepted Submission(s): 2088


Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 
 

Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.
 

Output
The output should be one integer per line, which means the minimal times of restarting machine.
 

Sample Input
  
  
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8 3 3 9 4 3 0
 

Sample Output
  
  
3
题目大意:机器调度问题,有两台机器,分别有n和m种工作状态,现有k个任务,需要用这两种机器来完成,由于每更换一次机器的工作状态都需要重启,因此,想要怎样安排这些任务,使得机器的重启次数最少,求最小的启动次数 思路:由于每个任务都可以用A或B机器的某种工作状态来完成,因此,对于每个任务,可以把A,B的工作状态作为顶点,在对应的A和B的工作状态间连线,则对于每条边的两个顶点,因为每个任务都要完成,故至少要有一个顶点(某个机器的一种状态)存在,这样这个问题就转化成了在这些顶点中选取尽量少的顶点(尽量少的工作状态,尽量少的重启次数),使得每一条边都至少和其中一个点相关联,即最小点覆盖问题。由于二分图的最小点覆盖数=最大匹配数,故可用匈牙利算法解决。   
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>
#include <stack>
#include <cstdlib>
using namespace std;

const int maxn=105;

int match[maxn];
bool vis[maxn],map[maxn][maxn];
int n,m,k;
bool find(int x)
{
    for(int i=1;i<m;i++)
    if(!vis[i]&&map[x][i])
    {
        vis[i]=true;
        if(match[i]==-1||find(match[i]))
        {
            match[i]=x;
            return true;
        }
    }
    return false;
}
int MMG()
{
    int ans=0;
    memset(match,-1,sizeof(match));
    for(int i=1;i<n;i++)
    {
        memset(vis,false,sizeof(vis));
        if(find(i)) ans++;
    }
    return ans;
}
int main()
{
    int x,y,c;
    while(scanf("%d",&n),n)
    {
        memset(map,false,sizeof(map));
        scanf("%d%d",&m,&k);
        for(int i=0;i<k;i++)
        {
           scanf("%d%d%d",&c,&x,&y);
           if(x&&y)
           map[x][y]=true;
        }
        printf("%d\n",MMG());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值