POJ 3069 Saruman's Army (贪心算法)

Saruman's Army
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13148 Accepted: 6593

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

先翻译题目:

给定一个范围 R 和排列在一条直线上的 N 个点 Xi(1…N),从中找出若干点,使这些点以 R 为半径的左右范围内包含剩余的所有点,求满足条件的最少的点的个数。

例如:1,7,15,20,30,50, 给定 R 为10,则符合条件的点为7,30,50


思路:

先对所给数字进行排序,然后从最左侧的点开始,寻找 R 范围内最远的点,标记,对左右 R 范围进行覆盖,然后寻找尚未被覆盖的范围最左侧的点,重复此过程,直到最后一个点。

#include<iostream>
#include<algorithm>
using namespace std;

int n, r;

void solve(int x[])
{
	sort(x, x + n);
	int ans = 0, i = 0;
	while(i < n)
	{
		int a = x[i];	//尚未被覆盖的最左侧的点
		i++;
		while(i < n && x[i] <= a + r)	//寻找a + r范围外第一个点的位置 
			i++;
		int b = x[i - 1];		//记录a + r范围内最远的点的位置, 即 b 
		while(i < n && x[i] <= b + r)	//寻找b + r范围外第一个点的位置 
			i++;
		ans++;		//统计数量 
	}	
	cout << ans << endl;
}

int main()
{
	while(cin >> r >> n && r != -1 && n != -1)
	{
		int x[1005];
		for(int i = 0; i < n; i++)
			cin >> x[i];
		solve(x);
	}
	return 0;	
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值