POJ 3618 Best Cow Line(贪心算法)

Best Cow Line
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 30454 Accepted: 8126

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

先简单翻译一下题目:

给定长度为N的字符串S,构造长度为N的新字符串T。T最初是一个空的字符串,每次从S的头部或尾部删除一个字符,添加到T的尾部,使T的字典序尽可能的小。图示如下:


图片截取自《挑战程序设计竞赛》第二版(秋叶拓哉)

这是一个经典的贪心算法题,每次在S的头尾中选择较小的添加到T尾,如果S的头尾相同,则比较头和尾的下一个字符,以此类推,于是便可得到如下算法:

将S反转,比较S与反转后的S的字典序,从S的头尾中选择小的加入到T的末尾,如果头尾相同,则可取任意一个。

#include<iostream>
#include<string>
using namespace std;

const int MAX = 2010;

char cow[MAX];

void solve(int n)
{
	string str = "";
	int left = 0, right = n - 1;
	bool flag = false;
	while(left <= right)	//比较头尾大小 
	{
		for(int i = 0; i <= right - left; i++)	
			if(cow[left + i] < cow[right - i])
			{
				flag = true;
				break;
			}
			else if(cow[left + i] > cow[right - i])
			{
				flag = false;
				break;
			}
		if(flag)
			str = str + cow[left++];
		else
			str = str + cow[right--];
	}
	for(int i = 0; i < str.length(); i++)	
	{
		if(i % 80 == 0 && i)	//每80个输出一个换行符 
			cout << endl;
		cout << str[i];
	}
	cout << endl;
}

int main()
{
	int n;
	cin >> n;
	for(int i = 0; i < n; i++)
		cin >> cow[i];
	solve(n);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值