Tree Recovery 【POJ - 2255】

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
This is an example of one of her creations:

                                               D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!

Input

The input will contain one or more test cases.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.
 

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB

思路:

因为学过离散,所以看输入输出就可以看懂题。

根据前序序列,中序序列推出来后序序列。

 

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int ans;
char a[30],b[30],c[30];

void fun(int l1,int k1,int l2,int k2)
{
    if( l1 > k1)      //结束条件
        return ;
    int sum = 0;
    while(b[ l2 + sum ] != a[ l1 ])       //循环
        sum++;
    fun(l1+1,l1+sum,l2,l2+sum-1);      
    fun(l1+sum+1,k1,l2+sum+1,k2);
    c[ans++]=a[l1];
}

int main()
{
    while(~scanf("%s%s",a,b)) //输入两组字符串
    {
        int l=strlen(a);        //测量长度
        ans=0;                  // 初始
        fun(0,l-1,0,l-1);       //递归循环
        c[l]=0;
        printf("%s\n",c);       //输出
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值