CSU1803 2016 同余

Description

 给出正整数 n 和 m,统计满足以下条件的正整数对 (a,b) 的数量:

1. 1≤a≤n,1≤b≤m;
2. a×b 是 2016 的倍数。

Input

输入包含不超过 30 组数据。
每组数据包含两个整数 n,m (1≤n,m≤109).

Output

对于每组数据,输出一个整数表示满足条件的数量。

Sample Input

32 63
2016 2016
1000000000 1000000000

Sample Output

1
30576
7523146895502644

HINT

Source


要求两个数的乘积是2016的倍数,那么只需他们对2016的模是2016的倍数即可。所以1 和 2017 在这个问题中其实是相同的,而全部化成对2016的模,方便计数。

可以用两层循环进行求解,因为所给时间很充足。

#include <iostream>
#include <cstdio>
#include <map>
#include <set>
#include <vector>
#include <queue>
#include <stack>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;
#define INF 0x3f3f3f3f
typedef long long LL;
LL a[2016],b[2016];
int main()
{std :: ios :: sync_with_stdio (false);
    LL n,m,ans;
    while(cin>>n>>m){
        ans=0;
        for(int i=0;i<2016;i++){
            a[i]=n/2016;
            b[i]=m/2016;
        }
        for(int i=1;i<=n%2016;i++){
            a[i]++;
        }
        for(int i=1;i<=m%2016;i++){
            b[i]++;
        }
        for(int i=0;i<2016;i++){
            for(int j=0;j<2016;j++){
                if((i*j)%2016==0){
                    ans+=a[i]*b[j];
                }
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值