hdu 6124 Euler theorem(水题)

http://acm.hdu.edu.cn/showproblem.php?pid=6124
Problem Description
HazelFan is given two positive integers a,b, and he wants to calculate amodb. But now he forgets the value of b and only remember the value of a, please tell him the number of different possible results.

Input
The first line contains a positive integer T(1≤T≤5), denoting the number of test cases.
For each test case:
A single line contains a positive integer a(1≤a≤109).

Output
For each test case:
A single line contains a nonnegative integer, denoting the answer.

Sample Input
2
1
3

Sample Output
2
3
题目大意:给你一个数a,输出a的余数个数。
解题思路:打表可以发现规律a的取值从1到10,余数个数分别是2,2,3,3,4,4,5,5,6,6……,可以找出通项公式a【n】=(n+1)/2+1;
最后直接输出就可以了。

#include <bits/stdc++.h>

using namespace std;

int main()
{
    int T;scanf("%d",&T);
    while(T--){
        int n;
        scanf("%d",&n);
        printf("%d\n",(n+1)/2+1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值