2019.3.23HDOJ-2026首字母变大写,AC率54.18%(46777/86337)

周六早上起来不知道干什么好,大物还一点不会呢

题目

Problem-2016首字母变大写
Problem Description
输入一个英文句子,将每个单词的第一个字母改成大写字母。

Input
输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。

Output
请输出按照要求改写后的英文句子。

Sample Input
i like acm
i want to get an accepted

Sample Output
I Like Acm
I Want To Get An Accepted

AC的代码

#include<stdio.h>
#include<ctype.h>
#define STLEN 150
int main(void)
{
	char str[STLEN];
	int inword,i;
	while(fgets(str,STLEN,stdin)!=NULL){
		for(i=0;i<STLEN;i++){
			inword=0;
			if(islower(str[i])!=0&&inword==0){
				str[i]-=32;
				inword=1;
			}
			while((isalpha(str[i])!=0&&inword==1)||(isalpha(str[i])==0&&inword==0)){
				i++;
			}
		}
		fputs(str,stdout);
	}
	return 0;
}

因为需要按行读入,所以用到了一直都没用过的fgets()函数。
调用了ctype.h,需要注意的是isalpha()在输入为字母和islower()在输入为小写字母是的返回值为非0,不一定是1,调试时好一顿忙活……

Run IDSubmit TimeJudge StatusPro.IDExe.TimeExe.MemoryCode Len.LanguageAuthor
286707312019-03-23 10:45:51Accepted202631MS1680K403 BCOverstars

2019年3月23日10点51分

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值