[POJ]1017 Packets

[POJ]1017 Packets

问题

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last “null” line of the input file.

Sample Input

0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0

Sample Output

2
1

分析

题目大意是工厂制造的产品形状都是长方体,它们的高度都是 h,长和宽都相等,一共有六个型号,他们的长宽分别为 1*1, 2*2, 3*3, 4*4, 5*5, 6*6。这些产品通常使用一个 6*6*h 的长方体包裹包装然后邮寄给客户。因为邮费很贵,所以工厂要想方设法的减小每个订单运送时的包裹数量。现在需要你编一个程序来帮助他们来节约费用。
简单的数学问题求解。可以分情况考虑:

  • 对于6*6的产品,每个会直接占用一个完整的箱子,并且没有空余空间
  • 对于5*5的产品,每个会占用一个箱子,并且留下11个1*1的空余空间
  • 对于4*4的产品,每个会占用一个箱子,并且留下5个2*2的空余空间
  • 对于3*3的产品,情况比较复杂,分四种情况考虑:
    • 产品数目正好是 4 的倍数,没有空余空间
    • 产品数目是 4 的倍数加 1,此时还剩 5 个 2*2 的空位和 7 个 1*1 的空位
    • 产品数目是 4 的倍数加 2,此时还剩 3 个 2*2 的空位和 6 个 1*1 的空位
    • 产品数目是 4 的倍数加 3,此时还剩 1 个 2*2 的空位和 5 个 1*1 的空位
  • 对于2*2和1*1的产品,情况比较简单,不再累述。

    因此可以推出数学公式,假设a,b,c,d,e,f分别代表1*1,2*2,3*3,4*4,5*5,6*6的数量,u[]={0,5,3,1}代表对于产品3*3剩余可以放2*2的数量。
    对于3*3,4*4,5*5,6*6,需要箱子数:
    n=d+e+f+(c+3)/4

    剩余2*2的空间:
    t=5d+u[c%4]

    对于2*2的箱子,需要增加的箱子数:
    n+=(bt+8)/9(2222)

    此时还剩余1*1的空间:
    t=36n36f25e16d9c4b

    对于1*1的箱子,需要增加的箱子数:
    n+=(at+35)/36(1111)

源代码

#include<iostream>
using namespace std;
int main()
{
    int n, a, b, c, d, e, f, t;
    int u[4] = { 0, 5, 3, 1 };
    while (cin >> a >> b >> c >> d >> e >> f && a | b | c | d | e | f)
    {
        n = d + e + f + (c + 3) / 4;
        t = 5 * d + u[c % 4];
        if (b>t) n += (b - t + 8) / 9;
        t = 36 * n - 36 * f - 25 * e - 16 * d - 9 * c - 4 * b;
        if (a>t)
            n += (a - t + 35) / 36;
        cout << n << endl;
    }
    return 0;
}

程序结果

ResultMemoryTimeLanguageCode Length
Accepted236K32MSC++297B
  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值