[POJ]1328 Radar Installation

#[POJ]1328 Radar Installation

问题

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations

这里写图片描述

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

分析

题目大意是有一个海岸线,是直线,沿海岸线建立坐标系,海岸线为X轴, 在X轴的上方是海,下方是陆地,海上有N个小岛,现在要在海岸线上安装雷达,雷达的覆盖范围是一个以d为半径的圆,请用最少的雷达覆盖所有的小岛;当无法覆盖时,输出-1。

思路:可以以小岛为圆心,d为半径画圆,求出这个圆交于X轴的两个坐标, l=xd2y2 r=x+d2y2 ,并按照其左坐标排序,从以下情况考虑:

  1. 圆1的r < 圆2的l;此时圆1与圆2不可能在一个雷达范围内。如图中圆1与圆4
  2. 圆1的r > 圆2的l && 圆1的r > 圆2的r;此时圆1与圆2在一个雷达范围内,且不用做修改。如图中的圆1与圆3
  3. 圆1的r > 圆2的l && 圆1的r < 圆2的r;此时圆1与圆2在一个雷达范围内,但是需要更新r值,r = 圆2的r。如图中的圆1与圆2

这里写图片描述

源代码

#include <iostream>
#include <vector>
#include <algorithm>
#include <cmath>
using namespace std;

struct site {
    double l, r;
    struct site(double x, double y) {
        l = x, r = y;
    }
};
bool cmp(site a, site b) {
    return a.l < b.l;
}
int main() {
    int n, d, i, Case = 0;
    double x, y, t;
    while (cin >> n >> d, (n + d)) {
        int ans = 1;
        vector<site> scope(n, site(0, 0));
        for (i = 0; i < n; i++) {
            cin >> x >> y;
            scope[i].l = x - sqrt(d*d - y*y);
            scope[i].r = x + sqrt(d*d - y*y);
            if (y > d || d <= 0 || y < 0) ans = -1;
        }
        sort(scope.begin(), scope.end(), cmp);
        t = scope[0].r;
        for (i = 1; i<n && ans != -1; i++)
            if (scope[i].l>t) {
                ++ans;
                t = scope[i].r;
            }
            else if (scope[i].r < t) t = scope[i].r;
        printf("Case %d: %d\n", ++Case, ans);
    }
    return 0;
}

程序结果

ResultMemoryTimeLanguageCode Length
Accepted248K47MSC++793B
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值