Case06_字典序问题,POJ3617

字典序问题

S0:ACDBCB
翻转过来
S1:BCBDCA
S0小 取头
S1小 取头
模板题

POJ3617

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input
* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output
The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input
6
A
C
D
B
C
B
Sample Output
ABCBCD

AC代码:

package greed_dynamic;

import java.util.Arrays;
import java.util.Scanner;

public class Pra {
  public static void main(String[] args) {
    Scanner sc = new Scanner(System.in);
    int N =sc.nextInt();
    StringBuilder s0 = new StringBuilder();
    for (int i = 0; i < N; i++) {
		s0.append(sc.next());
	}
    ff(s0.toString());
  }

  private static void ff(String s0) {
	// TODO 自动生成的方法存根
    String s1 = new StringBuilder(s0).reverse().toString(); 
    int N = s1.length();
    int cnt = 0;
    StringBuilder rs = new StringBuilder();
    while (rs.length() < N) {
		if (s0.compareTo(s1) <= 0) { //s0小
			rs.append(s0.charAt(0));
			s0 = s0.substring(1);
			
		} else {
			rs.append(s1.charAt(0));
			s1 = s1.substring(1);
		}
		//注意此题坑处,没80换行一次
		if (rs.length() % 80 == 0) {//取每次80的倍数
			System.out.println(rs.substring(cnt*80,(cnt+1)*80));
			cnt++;
		}
	}
    //80的倍数剩下还有,像余数一样
    if (rs.length() > cnt * 80) {
		System.out.println(rs.substring(cnt*80));
	}
  }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值