HDU 1164 Eddy's research I.doc

Problem Description

Eddy's interest is very extensive, recently he isinterested in prime number. Eddy discover the all number owned can be dividedinto the multiply of prime number, but he can't write program, so Eddy has toask intelligent you to help him, he asks you to write a program which can dothe number to divided into the multiply of prime number factor .

Input

The inputwill contain a number 1 < x<= 65535 per line representing the number ofelements of the set.

Output

You have toprint a line in the output for each entry with the answer to the previousquestion.

Sample Input

11

9412

Sample Output

11

2*2*13*181

 

#include <iostream>

#include <math.h>

using namespace std;

int prime(int x)

{

   int k=sqrt(1.0*x),i;

   bool flag=true;

    for(i=2;i<=k;i++)

       if(x%i==0)

       {

         flag=false;

         break;

       }

   return flag;

}

int main()

{

   int x,i;

   while(cin>>x)

    {

       while(x!=1)

       {

           for(i=2;i<=x;i++)

               if(x%i==0)

                    if(prime(i))

                    {

                      x=x/i;

                      if(x==1)

                        {

                           cout<<i<<endl;

                            break;

                        }

                      else

                       cout<<i<<"*";

                      i=1;

                    }

       }

    }

   return 0;

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值