LA-2512:Art Gallery(半平面交)

The art galleries of the new and very futuristic building of the Center for Balkan Cooperation have the form of polygons (not necessarily convex). When a big exhibition is organized, watching over all of the pictures is a big security concern. Your task is that for a given gallery to write a program which finds the surface of the area of the floor, from which each point on the walls of the gallery is visible. On the figure 1. a map of a gallery is given in some co-ordinate system. The area wanted is shaded on the figure 2. 
Input
The number of tasks T that your program have to solve will be on the first row of the input file. Input data for each task start with an integer N, 5 <= N <= 1500. Each of the next N rows of the input will contain the co-ordinates of a vertex of the polygon ? two integers that fit in 16-bit integer type, separated by a single space. Following the row with the co-ordinates of the last vertex for the task comes the line with the number of vertices for the next test and so on.
Output
For each test you must write on one line the required surface - a number with exactly two digits after the decimal point (the number should be rounded to the second digit after the decimal point).
Sample Input
1
7
0 0
4 4
4 7
9 7
13 -1
8 -6
4 -4
Sample Output
80.00

题意:给你一个多边形的画廊,找出一片区域,使得无论你站在这个区域的哪个地方,都能监视到画廊的各个地方。

思路:半平面交的模版题。求出半平面交的面积即可。(题目中给的点是按顺时针方向给出的,不过题目没有说明给出的顺序)

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
struct Point
{
    double x,y;
}p[2000],ch[2000];
struct Line
{
    Point p;
    Point v;
    double angle;
    Line(){}
    Line(Point p,Point v):p(p),v(v){angle=atan2(v.y,v.x);}
    bool operator<(const Line& L)const{return angle<L.angle;}
}L[2000];
double cross(Point a,Point b)   //ab叉积
{
	return (a.x*b.y-a.y*b.x);
}
Point Vector(Point a,Point b)     //向量ba
{
	Point c;
	c.x=a.x-b.x;
	c.y=a.y-b.y;
	return c;
}
double Polyarea(Point *p,int n)    //求多边形面积
{
	double area=0;
	for(int i=1;i<n-1;i++)
	{
		area+=cross(Vector(p[i],p[0]),Vector(p[i+1],p[0]));
	}
	return area/2;
}
bool Onleft(Line L,Point p){return cross(L.v,Vector(p,L.p))>0;}
Point Getinter(Line a,Line b)
{
    Point u=Vector(a.p,b.p);
    double t=cross(b.v,u)/cross(a.v,b.v);
    return (Point){a.p.x+a.v.x*t,a.p.y+a.v.y*t};
}
int Half(Line *L,int n,Point *poly)       //求半平面交上的点
{
    sort(L,L+n);
    int first,last;
    Point *p=new Point[n];
    Line *q=new Line[n];
    q[first=last=0]=L[0];
    for(int i=1;i<n;i++)
    {
        while(first<last&&!Onleft(L[i],p[last-1]))last--;
        while(first<last&&!Onleft(L[i],p[first]))first++;
        q[++last]=L[i];
        if(fabs(cross(q[last].v,q[last-1].v))<1e-7)
        {
            last--;
            if(Onleft(q[last],L[i].p))q[last]=L[i];
        }
        if(first<last)p[last-1]=Getinter(q[last-1],q[last]);
    }
    while(first<last&&!Onleft(q[first],p[last-1]))last--;
    if(last-first<=1)return 0;
    p[last]=Getinter(q[last],q[first]);
    int m=0;
    for(int i=first;i<=last;i++)poly[m++]=p[i];
    return m;
}
int main()
{
    int T,n;cin>>T;
    while(T--)
    {
        cin>>n;
        for(int i=0;i<n;i++)cin>>p[i].x>>p[i].y;
        for(int i=0;i<n;i++)L[i]=(Line){p[i],Vector(p[i],p[(i+1)%n])};
        int m=Half(L,n,ch);
        printf("%0.2f\n",Polyarea(ch,m));
    }
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值