POJ - 2352 :Stars

Stars

  POJ - 2352 


Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5
Sample Output
1
2
1
1
0
Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.


思路:因为x<=32000,可以用线段树做。每个节点记录一段区间内的星星数,每次插入一个星星,就可以找出x比它小的星星数,同时又因为是按y递增的顺序输入的,所以之前的星星的y坐标一定小于等于当前插入的星星的y坐标。

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX=32000+10;
struct lenka
{
	int l,r,sum;
}a[MAX<<2];
int n,ans,QWQ[MAX];
void build(int k,int l,int r)
{
	a[k].l=l,a[k].r=r;
	a[k].sum=0;
	if(l==r)return;
	build(2*k,l,(l+r)/2);
	build(2*k+1,(l+r)/2+1,r);
}
void insert(int k,int x)
{
	if(x==a[k].l&&x==a[k].r){ans+=a[k].sum;a[k].sum++;return;}  //x坐标相同的也要加上
	if(x>=a[2*k+1].l)ans+=a[2*k].sum,insert(2*k+1,x);    //左子树的星星x坐标都小于等于x
	else insert(2*k,x);
	a[k].sum=a[2*k].sum+a[2*k+1].sum;
}
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		build(1,0,32000);
		memset(QWQ,0,sizeof QWQ);
		for(int i=0;i<n;i++)
		{
			int x,y;
			scanf("%d%d",&x,&y);
			ans=0;
			insert(1,x);  //插入
			QWQ[ans]++;
		}
		for(int i=0;i<n;i++)printf("%d\n",QWQ[i]);
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值