HDU1102 Constructing Roads(kruskal最小生成树)

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25492    Accepted Submission(s): 9793


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 
 

Sample Input
  
  
3 0 990 692 990 0 179 692 179 0 1 1 2
 

Sample Output
  
  
179
 
Kruskal 算法是能够在O(mlogm) 的时间内得到一个最小生成树的算 法。它主要是基于贪心的思想:
1 将边按照边权从小到大排序,并建立一个没有边的图 T。 
2 选出一条没有被选过的边权最小的边。 
3 如果这条边两个顶点在 T 中所在的连通块不相同,那么将它加入图 T。 
4 重复 (2) 和 (3) 直到图 T 连通为止。 
由于只需要维护连通性,可以不需要真正建立图 T,可以用并查集来维护。

#include <bits/stdc++.h>
using namespace std;

const int N = 105;
struct Edge{
  int w,u,v;
}edge[N*N];
int n,q,node,a,b,fa,fb;
int pa[N];

int getpa(int a){
  if (pa[a] == a) return a;
    else return pa[a] = getpa(pa[a]);
}

bool cmp(Edge a,Edge b){
  return a.w < b.w;
}

int main(){
	while(~scanf("%d",&n)){
	  for (int i = 1;i <= n;i++){
    	pa[i] = i;
	  }
	  node = 0;
	  for (int i = 1;i <= n;i++){
	   	for (int j = 1;j <= n;j++){
	      int w;
    	  scanf("%d",&w);
	      if (j > i) {
	        edge[node].w = w;
    	    edge[node].u = i;
        	edge[node++].v = j;
    	  }
    	}
  	  }
  	  scanf("%d",&q);
      while(q--){
     	 scanf("%d%d",&a,&b);
    	 a = getpa(a);
    	 b = getpa(b);
    	 pa[a] = b;
  	  }
  	  sort(edge,edge+node,cmp);
      int ans = 0;
      for (int i = 0;i < node;i++){
        a = edge[i].u; b = edge[i].v;
        fa = getpa(a);fb = getpa(b);
        if (fa != fb){
          pa[fa] = fb;
          ans += edge[i].w;
        }
      }
      printf("%d\n",ans);
	}
  return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值