poj2481 Cows(树状数组)

Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good.

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E].

But some cows are strong and some are weak. Given two cows: cow i and cow j, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cow i is stronger than cow j.

For each cow, how many cows are stronger than her? Farmer John needs your help!
Input
The input contains multiple test cases.
For each test case, the first line is an integer N (1 <= N <= 10 5), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 10 5) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge.

The end of the input contains a single 0.
Output
For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cow i.
Sample Input
3
1 2
0 3
3 4
0
Sample Output
1 0 0
求每个区间是多少个区间的真子集 先按照r从大到小排序,r相同则按照l从小到大排序 用树状数组求前缀和 因为区间从0开始,所以给每个区间的l加1
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
#include <iostream>
using namespace std;
const int N = 100005;
struct Node{
    int l,r,id;
}node[N];
int n;
int num[N],c[N];

int lowbit(int x) {return x & (-x); }
int add(int x,int s){
    while(x <= n){
        c[x] += s;
        x += lowbit(x);
    }
}

int sum(int x){
    int s = 0;
    while(x > 0){
        s += c[x];
        x -= lowbit(x);
    }
    return s;
}

bool cmp(Node a,Node b){
    return a.r == b.r ? a.l < b.l : a.r > b.r;
}

int main(){
    while(~scanf("%d",&n) && n){
        for (int i = 1;i <= n;i++){
            scanf("%d%d",&node[i].l,&node[i].r);
            node[i].id = i;
        }
        sort(node+1,node+n+1,cmp);
        memset(c,0,sizeof(c));
        memset(num,0,sizeof(num));
        num[node[1].id] = 0;
        add(node[1].l+1,1);
        for (int i = 2;i <= n;i++){
            if ((node[i].r == node[i-1].r) && (node[i].l == node[i-1].l)){
                num[node[i].id] = num[node[i-1].id];
            }else{
                num[node[i].id] = sum(node[i].l+1);
            }
            add(node[i].l+1,1);
        }
        for (int i = 1;i <= n;i++){
            printf("%d%c",num[i],i == n ? '\n' : ' ');
        }
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值