POJ 3784 Running Median 动态求中位数 堆


For this problem, you will write a program that reads in a sequence of 32-bit signed integers. After each odd-indexed value is read, output the median (middle value) of the elements received so far.
Input
The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. The first line of each data set contains the data set number, followed by a space, followed by an odd decimal integer M, (1 ≤ M ≤ 9999), giving the total number of signed integers to be processed. The remaining line(s) in the dataset consists of the values, 10 per line, separated by a single space. The last line in the dataset may contain less than 10 values.
Output
For each data set the first line of output contains the data set number, a single space and the number of medians output (which should be one-half the number of input values plus one). The output medians will be on the following lines, 10 per line separated by a single space. The last line may have less than 10 elements, but at least 1 element. There should be no blank lines in the output.
Sample Input
3 
1 9 
1 2 3 4 5 6 7 8 9 
2 9 
9 8 7 6 5 4 3 2 1 
3 23 
23 41 13 22 -3 24 -31 -11 -8 -7 
3 5 103 211 -311 -45 -67 -73 -81 -99 
-33 24 56
Sample Output
 

1 51 2 3 4 52 59 8 7 6 53 1223 23 22 22 13 3 5 5 3 -3 -7 -3

题意。

1000个case

每个case  

输入若干个数,对第k个输入,如果k为奇数,则输出前k个数的中位数

那么这就是动态求中位数了

实现的思路也比较简洁

用两个堆, 大顶堆和小顶堆

每次输入一个数,如果这个数比当前的中位数大,就存入小顶堆中,  否则就存入大顶堆。

然后调整, 小顶堆元素的个数要等于大顶堆的元素个数,或者比其多1。 

如果小顶堆的元素太多,就塞到大顶堆里,反之亦然

这样一来就会发现。小顶堆的元素比所有大顶堆的元素都大, 而且小顶堆的堆顶就是中位数。 

那么怎么样才能想到这样一个思路。

中位数, 把这个序列分成两部分,  较大的一部分,较小的一部分。

每进来一个数,无非要么进入较大的一半,要么进入较小的一半

然后进来之后,再调整。

调整就是,要么较大的一部分的最小的数进入了较小的部分

要么反过来

这个过程我们用什么样的数据结构,  堆显然是比较好的

#include <cstdio>
#include <iostream>
#include <queue>
#include <algorithm>
#include <cstring>
using namespace std;
priority_queue <int,vector<int>,greater<int> > q1;//小顶堆
priority_queue <int,vector<int>,less<int> > q2;//大顶堆
int T,cas,n,a;
vector <int> G;

void add(int x){
    if (q1.empty()) {
        q1.push(x);
        return;
    }
    if (x > q1.top()) q1.push(x);
        else q2.push(x);
    while(q1.size() > q2.size() + 1){
        q2.push(q1.top());
        q1.pop();
    }
    while(q1.size() < q2.size()){
        q1.push(q2.top());
        q2.pop();
    }
}

int main(){
    scanf("%d",&T);
    while(T--){
        while(!q1.empty()) q1.pop();
        while(!q2.empty()) q2.pop();
        G.clear();
        scanf("%d%d",&cas,&n);
        for (int i = 0;i < n;i++){
            scanf("%d",&a);
            add(a);
            if (i % 2 == 0) G.push_back(q1.top());
        }
        printf("%d %d\n",cas,(n + 1) / 2);
        for(int i = 0; i < G.size(); i++) {  
            if(i > 0 && i % 10 == 0) putchar('\n');  
            if(i % 10) putchar(' ');  
            printf("%d", G[i]);  
        }  
        printf("\n");  
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值