A+B problem (压8位高精度加法模板)

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. 
InputThe first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 
OutputFor each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. 
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;
const int MAXN = 1005;
const int carry = 100000000;
char s1[MAXN],s2[MAXN];
int a1[MAXN],a2[MAXN];
int la,lb;
int n,t;

int change(char s[],int a[]){
    int len = strlen(s),i;
    char str[10] = {0};
    for (i = 0;len / 8;len -= 8){
        strncpy(str,s+len-8,8);
        a[i++] = atoi(str);
    }
    if (len){
        memset(str,0,sizeof(str));
        strncpy(str,s,len);
        a[i++] = atoi(str);
    }
    return i;
}

int add(int a[],int la,int b[],int lb){
    la = max(la,lb);
    for (int i = 0;i < la;i++){
        a[i] += b[i];
        a[i+1] += a[i] / carry;
        a[i] %= carry;
    }
    if (a[la]) la++;
    return la;
}

void print(int a[],int n){
    printf("%d",a[n-1]);//因为最高位格式不需保证有八位,故单独输出
    for (int i = n-2;i >= 0 ;i--){
        printf("%08d",a[i]);
    }
    printf("\n");
}

int main(){
    scanf("%d",&t);
    for (int i = 1;i <= t;i++){
        if (i != 1) printf("\n");
        printf("Case %d:\n",i);
        scanf("%s%s",s1,s2);
        printf("%s + %s = ",s1,s2);
        memset(a1,0,sizeof(a1));
        memset(a2,0,sizeof(a2));
        la = change(s1,a1);
        lb = change(s2,a2);
        la = add(a1,la,a2,lb);
		print(a1,la);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值