poj3094-Quicksum

A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document contents, and in many other situations where it is necessary to detect undesirable changes in data.

For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including consecutive spaces.

A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example Quicksum calculations for the packets "ACM" and "MID CENTRAL":

 ACM: 1*1  + 2*3 + 3*13 = 46

MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650

Input

The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters.

Output

For each packet, output its Quicksum on a separate line in the output.

Sample Input

ACM

MID CENTRAL

REGIONAL PROGRAMMING CONTEST

ACN

A C M

ABC

BBC

#

Sample Output

46

650

4690

49

75

14

15

题意:输入一串小于255的字符串,写一个算法,使其可以输出一个指定的数值,数值等于字符所在的位置*该字符代表的数,‘A’为1,‘B’为2...‘Z’为26,以‘#’结束输出,字符串只有大写字母和空格,空格可以是连续的。

1.确定输入格式,空格不代表结束以gets(a)输入字符串

2.当a[0]为‘#’时结束while循环

3.主要代码,以n记录当前字符的位置,sum记录当前字符的和

3.当a[i]为空格时,n++,sum不变,当a[i]为字符时,sum+=n*(a[i]-'A'+1)

4.当字符串结束后,输出sum的值

5.下次循环开始时,重置sum和n的值

其代码如下:

#include<cstdio>
using namespace std;
int main()
{
    char a[300];
    int n, sum;
    while(gets(a))
    {
        sum = 0;
        n = 1;
        if(a[0]=='#')
            break;
        for(int i = 0; a[i] != '\0'; i++)
        {
            if(a[i] == ' ')
            {
                n++;
                continue;
            }
            if(a[i] >='A' && a[i] <= 'Z')
            {
                sum += n*(a[i] - 'A'+1);
                n++;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值