A1009 Product of Polynomials

44 篇文章 0 订阅

description

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 3 3.6 2 6.0 1 1.6

idea

  • 在输入第二个多项式时,可变输入边计算
  • 注意相乘的话,指数最大为2000,则答案数组应该为2001

solution1(测试点4,5过不去,之后再填坑

#include <stdio.h>
int main(){
	int n, m, max[2] = {0}, count[2] = {0}, c = 0;
	double a[2][1001] = {{0.0}, {0.0}}, an, result[2001] = {0.0};
	for(int i = 0; i < 2; i++){//初始化两个多项式 
		scanf("%d", &n);
		while(n--){
			scanf("%d%lf", &m, &an);
			a[i][m] = an;
			if(m > max[i])
				max[i] = m;
			count[i]++;
		}
	}
	for(int i = 0; i <= max[0]; i++){
		for(int j = 0; j <= max[1]; j++){
			if(a[0][i] && a[1][j])
				result[i+j] += a[0][i] * a[1][j];
		}
	} 
	for(int i = 0; i < 1001; i++){
		if(result[i] != 0)
			c++;
	}
	printf("%d", c);
	for(int i = 2000; c; i--){
		if(result[i] != 0){
			printf(" %d %.1f", i, result[i]);
			c--;
		}
	}
	return 0;
}

solution2

#include <stdio.h>
int main(){
	int k, n, count = 0;
	double a[1001] = {0}, r[2001] = {0}, an;
	scanf("%d", &k);
	while(k--){
		scanf("%d%lf", &n, &an);
		a[n] = an;
	}
	scanf("%d", &k);
	while(k--){
		scanf("%d%lf", &n, &an);
		for(int i = 0; i < 1001; i++){
			if(a[i] != 0)
				r[i + n] += an * a[i];
		}
	}
	for(int i = 0; i < 2001; i++){
		if(r[i] != 0)
			count++;
	}
	printf("%d", count);
	for(int i = 2000; i >= 0; i--){
		if(r[i] != 0)
			printf(" %d %.1f", i, r[i]);
	}
	return 0;
} 

在这里插入图片描述

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值