PTA 甲级 1002 A+B for Polynomials (25分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1 a​N​1 N​2 a​N2… NK a​NK
where K is the number of nonzero terms in the polynomial, Ni and aN​i (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K<⋯<N2
​​<N1≤1000.

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:
3 2 1.5 1 2.9 0 3.2

**分析:**题中,先给出多项式A的非零项个数,按照指数从大到小输入各个非零项的指数与系数,然后同理以此格式输入B,最后同样按照此格式输出A+B。

**解题思路:**可设置一个double p[1001],来存贮各个非零项的系数(系数保留一位小数),数组下标即为指数,同时,由于为double型,注意判断精度。
代码如下:

#include<stdio.h>
#include<math.h>
int main(){
	double p[1003]={0},coef;
	int index,k,sum=0,i;
    for(int j=0;j<2;j++){
	scanf("%d",&k);
	for(i=0;i<k;i++){
		scanf("%d %lf",&index,&coef);
		p[index]+=coef;
	}
}
	for(i=0;i<1001;i++){	//用于统计A+B的非零项个数。
		if(p[i]!=0)	sum++;	
	}
	printf("%d%c",sum,sum>0?' ':'\n');	//若非零项为0,则输出换行,否则输出空格符。
	for(i=1000;i>=0;i--){
		if(fabs(p[i])>1e-3){ //double型需要进行此精确判断,由于题中为保留一位小数,所以右边取10^-3即可。
			sum--;	
			printf("%d %.1f%c",i,p[i],sum>0?' ':'\n');
		}
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值