1077 Kuchiguse

44 篇文章 0 订阅
日语以其独特的句尾粒子著称,这些粒子能反映说话者的个性。这一现象被称为Kuchiguse,在动漫中常被夸张表现,如用nyan~来塑造猫系角色。给定一系列字符台词,找出这个角色的Kuchiguse,即所有台词的最长公共后缀。
摘要由CSDN通过智能技术生成

description

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:

Itai nyan~ (It hurts, nyan~)

Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai

idea

  • 字符串中有空格不能用scanf()输入(scanf中%s以空白符作为结束标志,例如空格和换行)。可以用gets输入,相应的要及时吸收换行getchar()

字符数组的输入输出
(1)scanf&printf
%c 可识别空格和换行作为内容
%s 用空格或换行作为结束标志
(2)getchar&putchar
对象是单个字符
(3)gets&puts
gets识别换行作为输入结束(同scanf %s
所以如果输入其他再用gets时,要先用getchar吸收换行符

  • 最长后缀倒着判断,正着输出

solution

#include <stdio.h>
#include <string.h>
int main(){
	int n, m = 0, flag = 0;
	char s[100][257], result[257], t;
	scanf("%d", &n);
	getchar();
	for(int i = 0; i < n; i++) gets(s[i]);
	for(int i = strlen(s[0]) - 1; i >= 0; i--){
		t = s[0][i];
		for(int j = 1; j < n; j++){
			if(t != s[j][strlen(s[j]) - m - 1]) {
				flag = 1;
				break;
			}
		}
		if(!flag) result[m++] = t;
	}
	if(!m) printf("nai");
	for(int i = m - 1; i >= 0; i--) printf("%c", result[i]);
	return 0;
} 

春天的到来也会穿插倒春寒,春天并不会因此缺席。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值