1012 The Best Rank

44 篇文章 0 订阅

description

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output “N/A”.

Sample Input

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output

1 C
1 M
1 E
1 A
3 A
N/A

idea

  • 各种属性的优先级为:A平均分>C >M>E(其中平均分的比较实际上同总分的比较,还不用考虑取整方式)
  • 找最好的排名,同排名下找优先级最高的属性。
  • 排名老规矩:多人同分同排名,而后正常后延。如四个考研人分数为320,350,350,380,则其排名分别为1, 2, 2, 4

solution

#include <cstdio>
#include <algorithm>
using namespace std;
struct student{
	int id, grade[4];//分别代表 ACME的成绩,其中A直接取CME的和 
}stu[2010];
int g, Rank[1000000][4] = {0};//g是当前比较的属性0 A 1C 2M 3E 
bool cmp(student s1, student s2){
	return s1.grade[g] > s2.grade[g];
} 
int main(){
	int n, m, id, min;
	char hash[5] = "ACME";
	scanf("%d%d", &n, &m);
	for(int i = 0; i < n; i++){
		scanf("%d%d%d%d", &stu[i].id, &stu[i].grade[1], &stu[i].grade[2], &stu[i].grade[3]);
		stu[i].grade[0] = stu[i].grade[1] + stu[i].grade[2] + stu[i].grade[3];
	}
	for(g = 0; g < 4; g++){
		sort(stu, stu + n, cmp);
		Rank[stu[0].id][g] = 1;//排名从1开始 
		for(int i = 1; i < n; i++){
			if(stu[i-1].grade[g] == stu[i].grade[g]) Rank[stu[i].id][g] = Rank[stu[i-1].id][g]; 
			else Rank[stu[i].id][g] = i + 1;
		}
	}
	while(m--){
		scanf("%d", &id);
		if(Rank[id][0] == 0) printf("N/A");
		else{
			min = 0;
			for(int i = 1; i < 4; i++){
				if(Rank[id][min] > Rank[id][i]) min = i;
			}
			printf("%d %c", Rank[id][min], hash[min]);
		}
		if(m) printf("\n");
	}
	return 0;
}

反思

  • 编译错误error: reference to 'rank' is ambiguous,即rank重名了所以不确定是谁。定义的rank和库函数中函数名重了,可以把变量名改下或者干脆首字母大写。
    在这里插入图片描述

今天搜pat编译错误咋解决时,发现陈越老师的风评好像有些争议了。“眼看他起朱楼,眼看他宴宾客,眼看他楼塌了”真是精辟的总结。做好自己,问心无愧,不用贪心也不要着急,其他就随风而去吧。

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值