PAT甲级1081

Given N rational numbers in the form "numerator/denominator", you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers "a1/b1 a2/b2 ..." where all the numerators and denominators are in the range of "long int". If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form "integer numerator/denominator" where "integer" is the integer part of the sum, "numerator" < "denominator", and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

 

7/24

题目大意就是分数加法问题,最后结果要以(整数 分子/分母)的形式给出。

注意点:累加之前要对每一项约分,否则容易超出long int范围。

源码:

#include<iostream>
#include<algorithm>
using namespace std;
long gcd(long a,long b)
{
        return b==0?abs(a):gcd(b,a%b);
}
int main()
{
    long n,a,b,suma=0,sumb=1,gcdvalue;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        scanf("%ld/%ld",&a,&b);
        gcdvalue=gcd(a,b);
        a=a/gcdvalue;
        b=b/gcdvalue;
        suma=a*sumb+b*suma;
        sumb=b*sumb;
        gcdvalue=gcd(suma,sumb);
        suma=suma/gcdvalue;
        sumb=sumb/gcdvalue;
    }
    long iint=suma/sumb;
    suma=suma-(sumb*iint);
    if(iint!=0)
    {
        cout<<iint;
        if(suma!=0)
            cout<<" ";
    }
    if(suma!=0)
        cout<<suma<<"/"<<sumb;
    if(iint==0&&suma==0)
        cout<<0;

    return 0;
}

其中,gcd(long a,long b)函数是求a和b的最大公约数gcdvalue,然后a/gcdvalue, b/gcdvalue就是最简分数的分子和分母。



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值