PAT甲级 1029

51 篇文章 0 订阅
1 篇文章 0 订阅

Median

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output

For each test case you should output the median of the two given sequences in a line.

Sample Input
4 11 12 13 14
5 9 10 15 16 17
Sample Output
13


  1. 考点

    1. 二分法
  2. 题解

    1. 分为2个二分
    2. 第一个二分,寻找中位数。第二个二分统计小于当前这个数的个数。
    3. 如何当前2个二分找的位置之和等于整个list的一半,即为中位数。
#include<iostream>
#include<stdio.h>
using namespace std;
const int maxn=1000000+10;
typedef long long ll;
ll firstSequence[maxn],secondSequence[maxn];
int input_data(ll num[]){
    int n;
    scanf("%d",&n);
    int i;
    for(i=1;i<=n;i++){
        scanf("%lld",num+i);
    }
    return n;
}
int getNumOfLess(ll value,int n,ll num[]){
    int low=1,high=n,mid;
    while(low<=high){
        mid=(low+high)/2;
        if(value<num[mid]){
            high=mid-1;
        }else{
            low=mid+1;
        }
    }
    return low-1;
}
ll findMedian(ll num1[],int n1,int n2,ll num2[]){
    ll rst=-1;
    int low=1,high=n1,mid;
    int pos;
    while(low<=high){
        mid=(low+high)/2;
        pos=getNumOfLess(num1[mid],n2,num2);
        if(mid+pos==(n1+n2+1)/2){
            rst=num1[mid];
            break;
        }else if(mid+pos<(n1+n2+1)/2){
            low=mid+1;
        }else{
            high=mid-1;
        }
    }
    return rst;
}
int main(){
    freopen("./in","r",stdin);
    int n1,n2;
    ll rst;
    n1=input_data(firstSequence);
    n2=input_data(secondSequence);
    rst=max(findMedian(firstSequence,n1,n2,secondSequence),findMedian(secondSequence,n2,n1,firstSequence));
    printf("%lld",rst);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值