PAT甲级1029(中位数)

1029 Median (25 point(s))

  Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.
  Given two increasing sequences of integers, you are asked to find their median.

Input Specification:
  Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10​5) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:
  For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

题目大意

  给定两个数列,个数分别为N1,N2,求出其中位数,注意如果N1+N2为偶数,则返回第(N1+N2) / 2 - 1个数(从0开始)

解题思路

  用i,j分别指向两个数组,比较对应位置数的大小,以决定++i还是++j。说起来很麻烦,看代码比较简单

代码

#define _CRT_SECURE_NO_WARNINGS
#include <cstdio>

const int MAXN = 200005;
long long arr1[MAXN], arr2[MAXN];//分别存储两个数列
int main()
{
	long long num;
	int N1, N2, i, j;
	int ret = scanf("%d", &N1);
	for (i = 0; i < N1; ++i) {
		ret = scanf("%lld", &arr1[i]);
	}
	ret = scanf("%d", &N2);
	for (i = 0; i < N2; ++i) {
		ret = scanf("%lld", &arr2[i]);
	}
	i = j = 0;
	int mid = (N1 + N2) >> 1;//中间位置
	while (i < N1 && j < N2) {//如果N1+N2为偶数,则中位数为左半部分的最后一个数
		if (i + j == mid && (N1 + N2) % 2 == 1 || i + j == mid - 1 && (N1 + N2) % 2 == 0) {
			printf("%lld\n", arr1[i] < arr2[j] ? arr1[i] : arr2[j]);
			return 0;
		}
		if (arr1[i] < arr2[j]) ++i;
		else ++j;
	}
	if (i < N1 && mid >= j) {
		printf("%lld\n", arr1[mid - j]);
	}
	else if(j < N2 && mid >= i){
		printf("%lld\n", arr2[mid - i]);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值