Rental Service 洛谷p4181

题意翻译

farmer john有N(1≤N≤100,000)头牛,他想赚跟多的钱,所以他准备买牛奶和出租牛。有M(1≤M≤100,000 )家商店想买牛奶,每家商店的进货价不同。有R(1≤R≤100,000 )户邻居想租牛,每户人家的租价不同。 问他最多能赚多少钱。

输入:输入的第1行包含n,m,r三个整数。紧接着的n行每一行有1个整数Ci (1≤Ci≤1,000,000),表示第i头牛产出Ci加仑奶。再下面的m行每行有两个整数Qi与Pi (1≤Qi,Pi≤1,000,000),表示第i个商店最多以Pi美分每加仑的价格购买Qi加仑牛奶。FJ可销售0~Qi加仑牛奶到一个商店。然后的r行每行有一个整数Ri,表示FJ的第i个邻居想以Ri(1≤Ri≤1,000,000 ), 的价格租一头牛。

输出:仅一行。表示一天最多获得多少钱。

注意:int类型不够大!!!

说明: FJ 需要挤一号和四号奶牛的奶,共可得牛奶13加仑。他可以先买给出价最高的10加仑,赚250美分,然后把剩下的按每加仑15美分去卖,共有295美分的利润。 然后,他要把其他三头以250,80,和100美分的价格分别卖出,赚430美分。所以他一共可得725美分/日的利润。

---by 风格雨关、WuYongxuan、毕沁露

题目描述

Farmer John realizes that the income he receives from milk production is insufficient to fund the growth of his farm, so to earn some extra money, he launches a cow-rental service, which he calls "USACOW" (pronounced "Use-a-cow").

Farmer John has NN cows (1 \leq N \leq 100,0001≤N≤100,000), each capable of producing some amount of milk every day. The MM stores near FJ's farm (1 \leq M \leq 100,0001≤M≤100,000) each offer to buy a certain amount of milk at a certain price. Moreover, Farmer John's RR (1 \leq R \leq 100,0001≤R≤100,000) neighboring farmers are each interested in renting a cow at a certain price.

Farmer John has to choose whether each cow should be milked or rented to a nearby farmer. Help him find the maximum amount of money he can make per day.

输入输出格式

输入格式:

 

The first line in the input contains NN, MM, and RR. The next NN lines each contain an integer c_ici​ (1 \leq c_i \leq 1,000,0001≤ci​≤1,000,000), indicating that Farmer John's iith cow can produce c_ici​ gallons of milk every day. The next MM lines each contain two integers q_iqi​ and p_ipi​ (1 \leq q_i, p_i \leq 1,000,0001≤qi​,pi​≤1,000,000), indicating that the iith store is willing to buy up to q_iqi​ gallons of milk for p_ipi​ cents per gallon. Keep in mind that Farmer John can sell any amount of milk between zero and q_iqi​ gallons to a given store. The next RR lines each contain an integer r_iri​ (1 \leq r_i \leq 1,000,0001≤ri​≤1,000,000), indicating that one of Farmer John's neighbors wants to rent a cow for r_iri​ cents per day.

 

输出格式:

 

The output should consist of one line containing the maximum profit Farmer John can make per day by milking or renting out each of his cows. Note that the output might be too large to fit into a standard 32-bit integer, so you may need to use a larger integer type like a "long long" in C/C++.

 

输入输出样例

输入样例#1: 复制

5 3 4
6
2
4
7
1
10 25
2 10
15 15
250
80
100
40

输出样例#1: 复制

725

说明

Farmer John should milk cows #1 and #4, to produce 13 gallons of milk. He should completely fill the order for 10 gallons, earning 250 cents, and sell the remaining three gallons at 15 cents each, for a total of 295 cents of milk profits.

Then, he should rent out the other three cows for 250, 80, and 100 cents, to earn 430 more cents. (He should leave the request for a 40-cent rental unfilled.) This is a total of 725 cents of daily profit.

 

若要出租i头牛,肯定是出租给开价最高的前i个邻居。

若要卖i头牛的牛奶,肯定选择产量前i高的奶牛,尽量卖给出价高的。

#include<bits/stdc++.h>
#define f(i,l,r) for(i=(l);i<=(r);i++)
using namespace std;
const long long MAXN=100005;
struct Node{
	long long q,p,w,v;
}a[MAXN];
long long n,m,R;
long long x[MAXN],y[MAXN];
long long ans;
bool cmp(long long a,long long b)
{
	return a>b;
}
bool cmp1(Node a,Node b)
{
	return a.p>b.p;
}
bool cmp2(Node a,Node b)
{
	return a.w<b.w;
}
long long sell(long long num)
{
	if(x[num]>a[m].w) return a[m].v;
	Node tmp;
	tmp.w=x[num];
	int pos=lower_bound(a+1,a+1+m,tmp,cmp2)-a;
	return a[pos].v-(a[pos].w-x[num])*a[pos].p;
}
int main()
{
	ios::sync_with_stdio(false);
	int i,j;
	cin>>n>>m>>R;
	f(i,1,n){
		cin>>x[i];
	}
	sort(x+1,x+1+n,cmp);  //挤奶量从大到小排。
	f(i,1,n){
		x[i]+=x[i-1];
	}
	f(i,1,m){
		cin>>a[i].q>>a[i].p;	
	}
	sort(a+1,a+1+m,cmp1);
	f(i,1,m){
		a[i].w=a[i-1].w+a[i].q;
		a[i].v=a[i-1].v+a[i].p*a[i].q; 
	}
	f(i,1,R){
		cin>>y[i];
	}
	sort(y+1,y+1+R,cmp);
	f(i,1,R){
		y[i]+=y[i-1];
	}
	f(i,0,R){
		ans=max(ans,y[i]+sell(n-i));
		if(i==n) break;
	} 
	cout<<ans<<endl;
	return 0;	
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值