[Trie树]HDU - 1671 Phone List (字典树)

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO

YES

 

想法:把每一个串重点字母标记为1,其他为0,然后在update的过程中如果有1就说明有覆盖。
1
3
999 99 9

然后wa在这个样例上。骤然醒悟,要先按照长度排序。

 

#include<cstdio>
#include<cstring>
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;
char s[15];
int tree[500005][10],num[500005],cnt,flag;
struct node{
    string s;
}e[10000];
bool cmp(node a,node b){
    return a.s.length()<b.s.length();
}

void update(string s)
{
    if(!flag)   return;
    int len=s.length(),pos=0;
  //  printf("    %d\n",len);
    for(int i=0;i<len;i++){
        int n=(int)(s[i]-'0');
        if(tree[pos][n]==0){
            tree[pos][n]=++cnt;
        }
        pos=tree[pos][n];
      //  printf("%c num=\n",s[i]);
        if(num[pos]!=0){
            flag=0;
            return;
        }
    }
    num[pos]++;
    return;
}

int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--){
        flag=1;
        cnt=0;
        memset(tree,0,sizeof(tree));
        memset(num,0,sizeof(num));
        scanf("%d",&n);
        for(int i=0;i<n;i++){
                cin>>e[i].s;
        }
        sort(e,e+n,cmp);
        for(int i=0;i<n;i++){
            update(e[i].s);
        }

        if(flag)    printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值