poj1852 Ants

Time Limit: 1000MS Memory Limit: 30000K

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

分析:如果对于每一个蚂蚁进行模拟,时间复杂度显然无法胜任;换一个角度,由于蚂蚁各个相等,所以两只蚂蚁碰头后回头等价于同一只蚂蚁沿着原方向继续走。计算一只蚂蚁所需的最大时间即可。

#include<cstdio>
#include<algorithm>
#define N 1000100
int a[N],ans1,ans2,L,n;
using namespace std;
void findMIN()
{
	int mint;
	ans1=-1;
	for(int i=0;i<n;++i)
	{
		mint = min(a[i],L-a[i]);
		ans1 = max(ans1,mint);
	}
	printf("%d ",ans1);
}
 
void findMAX()
{
	int maxt;
	ans2=-1;
	for(int i=0;i<n;++i)
	{
		maxt = max(a[i],L-a[i]);
		ans2 = max(ans2,maxt);
	}
	printf("%d\n",ans2);
}
 
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&L,&n);
		for(int i=0;i<n;++i)
			scanf("%d",&a[i]);
		findMIN();
		findMAX();
	}
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值