POJ 1852 Ants(弹性碰撞问题)

Ants

Time Limit: 1000MS


Memory Limit: 30000K

Total Submissions: 12607


Accepted: 5525

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.


Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.


Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 


Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191


Sample Output

4 8
38 207


题意:在一根长为L的水平木棍上有一群数量为n的蚂蚁,它们以每秒1cm/s的速度走到木棍一端就会掉下去。现在知道它们的起始位置是距离木根左端点的x处。但是不知道它们爬行的方向。在相向而行的两只蚂蚁相遇后,它们会掉头往反方向走。问所有蚂蚁都落下木棍的最快时间和最慢时间。


题解:一开始觉得可以暴搜,每只蚂蚁只有两种情况,不过掉头的事情感觉很复杂。时间复杂度为2的n次幂。肯定超时。  因为是同时出发的,相遇时的两只蚂蚁用的时间是相同的,我们可以无视蚂蚁的区别,当两只蚂蚁相遇时它们保持原样交错而行。这样每只蚂蚁都是独立运动的,那么只要找每只蚂蚁掉下去的时间就行了。


代码如下:


#include<cstdio>
#define maxn 1000100
int a[maxn],ansmin,ansmax,L,n;

int MIN(int a,int b)
{
	return a<b?a:b;
}

int MAX(int a,int b)
{
	return a>b?a:b;
}

void ansMIN()
{
	int i,min;
	ansmin=-1;
	for(i=0;i<n;++i)
	{
		min=MIN(a[i],L-a[i]);
		if(min>ansmin)
			ansmin=min;
	}
	printf("%d ",ansmin);
}

void ansMAX()
{
	int i,max;
	ansmax=-1;
	for(i=0;i<n;++i)
	{
		max=MAX(a[i],L-a[i]);
		if(max>ansmax)
			ansmax=max;
	}
	printf("%d\n",ansmax);
}

int main()
{
	int i,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&L,&n);
		for(i=0;i<n;++i)
			scanf("%d",&a[i]);
		ansMIN();//求所有蚂蚁掉下去的最短时间 
		ansMAX();//求所有蚂蚁掉下去的最长时间 
	}
	return 0;
} 




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值