HDU 1423 Greatest Common Increasing Subsequence (LCIS)

Greatest Common Increasing Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7667    Accepted Submission(s): 2480


Problem Description
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.
 

Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.
 

Output
output print L - the length of the greatest common increasing subsequence of both sequences.
 

Sample Input
  
  
1 5 1 4 2 5 -12 4 -12 1 2 4
 

Sample Output
  
  
2
 

Source

ACM暑期集训队练习赛(二)



垃圾题目没有说输出之间应有一个空行,会PE。

LCIS裸题。


#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;
int a[555],b[555];
int f[555];
int main()
{
    int T;
    scanf("%d",&T);
    int p=0;
    while(T--)
    {

        int l1,l2;
        scanf("%d",&l1);
        for(int i=1;i<=l1;i++) scanf("%d",&a[i]);
        scanf("%d",&l2);
        for(int i=1;i<=l2;i++) scanf("%d",&b[i]);
        memset(f,0,sizeof f);
        for(int i=1;i<=l1;i++)
        {
            int k=0;//f[k]=0就好
            for(int j=1;j<=l2;j++)
            {
                if(a[i]==b[j])
                {
                    f[j]=max(f[j],f[k]+1);
                }
                else if(a[i]>b[j])
                {
                    if(f[k]<f[j])
                        k=j;
                }
            }
        }
        if(p)
            printf("\n");
        p++;
        int ans=0;
        for(int i=1;i<=l2;i++)
            ans=max(ans,f[i]);
        printf("%d\n",ans);
    }
    return 0;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值