HDU 2669 Romantic(拓展欧几里得)


Romantic

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6585    Accepted Submission(s): 2757


Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You. 
................................Write in English class by yifenfei

 

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
 

Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
 

Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 
 

Sample Input
      
      
77 51 10 44 34 79
 

Sample Output
      
      
2 -3 sorry 7 -3
 

Author
yifenfei
 

Source

题意:
X*a + Y*b = 1.给你a b,求x y,x要最小非负数。

point:
拓展欧几里得:

a * x + b * y = c的整数解

先计算Gcd(a,b),若c不能被Gcd(a,b)整除,则方程无整数解;否则,在方程两边同时除以Gcd(a,b),得到新的不定方程a' * x + b' * y = c'

x = c' * x0 + b' * t

y = c' * y0 - a' * t


#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define ll long long
int exgcd(int a,int b,int &x,int &y)//ax+by=gcd(a,b);
{
    int d=a;
    if(b!=0)
    {
        d=exgcd(b,a%b,y,x);
        y=y-(a/b)*x;
    }
    else
    {
        x=1;
        y=0;
    }
    return d;
}
int main()
{
    int a,b;
    while(~scanf("%d %d",&a,&b))
    {
        int flag=0;
        if(a<b) swap(a, b),flag=1;
        int x,y;
        int d=exgcd(a,b,x,y);
        if(d!=1) printf("sorry\n");
        else
        {
            if(flag)
            {
                if(y<0)
                {
                    y=y+a/d;
                    x=x-b/d;
                }
                printf("%d %d\n",y,x);
            }
            else
            {
                if(x<0)
                {
                    x=x+b/d;
                    y=y-a/d;
                }
                printf("%d %d\n",x,y);
            }
        }
        
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值