Romantic
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2958 Accepted Submission(s): 1160
Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
................................Write in English class by yifenfei
Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
................................Write in English class by yifenfei
Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
Each case two nonnegative integer a,b (0<a, b<=2^31)
Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.
Sample Input
77 51 10 44 34 79
Sample Output
2 -3 sorry 7 -3
Author
yifenfei
Source
通过扩展欧几里得算法求得x,y之后,要求所有的x和y的解的话,得求得通项公式:(x+k*gx , y-k*gy) gx= b/gcd(a,b),gy = a/gcd(a,b)互素,k为任意整数
//15MS 228K
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
#include<vector>
#define M 10007
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
long long extended_euclidean(long long n, long long m, long long &x, long long &y)
{
if (m == 0)
{
x = 1;
y = 0;
return n;
}
long long g = extended_euclidean(m, n % m, x, y);
long long t = x - n / m * y;
x = y;
y = t;
return g;
}
int main()
{
ll a,b,x,y;
while(scanf("%I64d%I64d",&a,&b)!=EOF)
{
ll d=extended_euclidean(a,b,x,y);
if(1%d)printf("sorry\n");
else
{
while(x<0){x+=b;y-=a;}
printf("%I64d %I64d\n",x,y);
}
}
return 0;
}