HDU 1005 Number Sequence(矩阵快速幂)

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 176161    Accepted Submission(s): 43556


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 

Author
CHEN, Shunbao
 

Source
 

这种形势的然后n又非常大的就是构造矩阵然后快速幂了。

矩阵是:A B     和 1 0

  1  0 1 0

原本想用费马小定理减少时间的,发现矩阵的幂好像是不能降的,没学过嘛也不清楚,WA了一发。

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
const int p = 7;
int gcd(int a,int b)
{
    if(a<b) swap(a,b);
    return b==0?a:gcd(b,a%b);
}
struct mx
{
    int a[3][3];
};

mx chen(mx a,mx b)
{
    mx ans;
    for(int i=1;i<=2;i++)
    {
        for(int j=1;j<=2;j++)
        {
            ans.a[i][j]=0;
            for(int k=1;k<=2;k++)
            {
                (ans.a[i][j]+=a.a[i][k]*b.a[k][j])%=p;
            }
        }
    }
    return ans;
}
mx mxqkm(mx base,int mi)
{
    mx ans;
    ans.a[1][1]=ans.a[2][2]=1,ans.a[1][2]=ans.a[2][1]=0;
    while(mi)
    {
        if(mi&1) ans=chen(ans,base);
        mi>>=1;
        base=chen(base,base);
    }
    return ans;
}
int main()
{
    int a,b,n;
    while(~scanf("%d %d %d",&a,&b,&n))
    {
        if(a==0&&b==0&&n==0) break;
        if(n<=2)
        {
            printf("1\n");
            continue;
        }
        n-=2;
        if(gcd(n,7)==1)
        {
           // n=n%6;
        }
        a%=7,b%=7;
        mx base;
        base.a[1][1]=a,base.a[1][2]=b,base.a[2][1]=1,base.a[2][2]=0;
        mx ans=mxqkm(base,n);
        int now=ans.a[1][1]+ans.a[1][2];
        printf("%d\n",now%7);
        
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值