【矩阵快速幂】HDU_1005_Number Sequence

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 177435    Accepted Submission(s): 44019


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 

Author
CHEN, Shunbao
 

Source
 

Recommend
JGShining
#include <bits/stdc++.h>
using namespace std;
const int maxn=2;
typedef struct node{
    int a[maxn][maxn];
    node(){
        memset(a,0,sizeof(a));
    }
}Matrix;
Matrix multiply(Matrix x,Matrix y,int mod){
    Matrix ans;
    for(int i=0;i<maxn;i++){
        for(int j=0;j<maxn;j++){
            for(int k=0;k<maxn;k++){
                ans.a[i][j]=(ans.a[i][j]+x.a[i][k]*y.a[k][j])%mod;
            }
        }
    }
    return ans;
}
Matrix quickpow(Matrix x,int a,int mod){
    Matrix ans;
    for(int i=0;i<maxn;i++)
        ans.a[i][i]=1;
    while(a){
        if(a&1)
            ans=multiply(ans,x,mod);
        x=multiply(x,x,mod);
        a>>=1;
    }
    return ans;
}
void Print(Matrix x){
    for(int i=0;i<maxn;i++){
        for(int j=0;j<maxn;j++)
            printf("%d ",x.a[i][j]);
        printf("\n");
    }
}
int main()
{
    int A,B,n;
    while(~scanf("%d%d%d",&A,&B,&n)){
        if(A==0&&B==0&&n==0) break;
        if(n<3){
            printf("%d\n",1);
            continue;
        }
        Matrix m,base;
        base.a[0][0]=base.a[0][1]=1;
        m.a[0][0]=A;
        m.a[1][0]=B;
        m.a[0][1]=1;
        m.a[1][1]=0;
        Matrix ans=quickpow(m,n-2,7);
//        Print(ans);
        ans=multiply(base,ans,7);
        printf("%d\n",ans.a[0][0]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值