HDU Find the hotel(RMQ)

5 篇文章 0 订阅

Find the hotel

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 611    Accepted Submission(s): 201


Problem Description
  Summer again! Flynn is ready for another tour around. Since the tour would take three or more days, it is important to find a hotel that meets for a reasonable price and gets as near as possible! 
  But there are so many of them! Flynn gets tired to look for any. It’s your time now! Given the <p i, d i> for a hotel h i, where p i stands for the price and d i is the distance from the destination of this tour, you are going to find those hotels, that either with a lower price or lower distance. Consider hotel h 1, if there is a hotel h i, with both lower price and lower distance, we would discard h1. To be more specific, you are going to find those hotels, where no other has both lower price and distance than it. And the comparison is strict.
 

Input
There are some cases. Process to the end of file.
Each case begin with N (1 <= N <= 10000), the number of the hotel.
The next N line gives the (p i, d i) for the i-th hotel.
The number will be  non-negative and less than 10000.
 

Output
First, output the number of the hotel you find, and from the next line, print them like the input( two numbers in one line). You should order them ascending first by price and break the same price by distance.
 

Sample Input
  
  
3 15 10 10 15 8 9
 

Sample Output
  
  
1 8 9
 

Author
ZSTU
 

Source
 
题意:
找特定旅馆的数量,这个旅馆的p和d不能都比其他旅馆大。可以相等。

POINT:
先给p从小到大排个序,然后选定一个旅馆p0 d0,从价格0-(p0-1)的范围内找到d最小的,和d0比较,符不符合要求就是了。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;
#define LL long long
const int N = 10000+5;
struct node
{
    int p,d;
}h[N],ans[N];
int dp[N][20];
int n;
bool cmd(node a,node b)
{
    if(a.p!=b.p)
    {
        return a.p<b.p;
    }
    else
        return a.d<b.d;
}
void prermq()
{
    for(int i=1;i<=n;i++)
    {
        dp[i][0]=h[i].d;
    }
    for(int j=1;1<<j<=n;j++)
    {
        for(int i=1;i-1+(1<<j)<=n;i++)
        {
            dp[i][j]=min(dp[i][j-1],dp[i+(1<<(j-1))][j-1]);
        }
    }
}
int query(int l,int r)
{
    int k=(int)log2((double)(r-l+1));
    return min(dp[l][k],dp[r+1-(1<<k)][k]);
}
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d %d",&h[i].p,&h[i].d);
        }
        sort(h+1,h+1+n,cmd);
        prermq();
        int cnt=0;
        for(int i=1;i<=n;i++)
        {
            int j=i-1;
            while(j!=0&&h[j].p==h[i].p)
            {
                j--;
            }
            if(j==0)
                ans[++cnt]=h[i];
            else
            {
                int d=query(1,j);
                if(h[i].d<=d)
                {
                    ans[++cnt]=h[i];
                }
            }
        }
        printf("%d\n",cnt);
        sort(ans+1,ans+1+cnt,cmd);
        for(int i=1;i<=cnt;i++)
        {
            printf("%d %d\n",ans[i].p,ans[i].d);
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值