POJ 2402 Palindrome Numbers

49 篇文章 0 订阅
Palindrome Numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3943 Accepted: 1502

Description

A palindrome is a word, number, or phrase that reads the same forwards as backwards. For example, the name "anna" is a palindrome. Numbers can also be palindromes (e.g. 151 or 753357). Additionally numbers can of course be ordered in size. The first few palindrome 
numbers are: 1, 2, 3, 4, 5, 6, 7, 8, 9, 11, 22, 33, ... 
The number 10 is not a palindrome (even though you could write it as 010) but a zero as leading digit is not allowed.

Input

The input consists of a series of lines with each line containing one integer value i (1<= i <= 2*10^9 ). This integer value i indicates the index of the palindrome number that is to be written to the output, where index 1 stands for the first palindrome number (1), index 2 stands for the second palindrome number (2) and so on. The input is terminated by a line containing 0.

Output

For each line of input (except the last one) exactly one line of output containing a single (decimal) integer value is to be produced. For each input value i the i-th palindrome number is to be written to the output.

Sample Input

1
12
24
0

Sample Output

1
33
151

Source

题意:

输出第n个回文数字。


POINT:

一直用搜索做,做不出。

先求出第n个的长度,然后截一半,从10**0开始数,第k个就是答案。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
using namespace std;
#define  LL long long
LL a[20];
void init()
{
    a[1]=9;
    a[2]=9;
    for(int i=3;;i++)
    {
        a[i]=a[i-2]*10;
        if(a[i]>=2*1e9) break;
    }
}
int main()
{
    LL n;
    init();
    while(~scanf("%lld",&n)&&n)
    {
        LL now=0;
        int i;
        for(i=1;;i++)
        {
            now+=a[i];
            if(now>=n)
                break;
        }
        int k=i;
        n=n-now+a[i];
        int l;
        if(k&1) l=k/2+1;
        else l=k/2;
        now=(LL)pow(10,l-1);
        LL ans=now+n-1;
        printf("%lld",ans);
        int anss[20];
        for(int i=1;i<=l;i++)
        {
            anss[i]=ans%10;
            ans/=10;
        }
        if(k&1) i=2;
        else i=1;
        for(;i<=l;i++)
        {
            printf("%d",anss[i]);
        }
        printf("\n");
        
    }
    
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值