HDU 6168 Numbers(排序)

80 篇文章 0 订阅

Numbers

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 81    Accepted Submission(s): 38


Problem Description
zk has n numbers  a1,a2,...,an . For each (i,j) satisfying 1≤i<j≤n, zk generates a new number  (ai+aj) . These new numbers could make up a new sequence  b1b2,...,bn(n1)/2 .
LsF wants to make some trouble. While zk is sleeping, Lsf mixed up sequence a and b with random order so that zk can't figure out which numbers were in a or b. "I'm angry!", says zk.
Can you help zk find out which n numbers were originally in a?
 

Input
Multiple test cases(not exceed 10).
For each test case:
The first line is an integer m(0≤m≤125250), indicating the total length of a and b. It's guaranteed m can be formed as n(n+1)/2.
The second line contains m numbers, indicating the mixed sequence of a and b.
Each  ai  is in [1,10^9]
 

Output
For each test case, output two lines.
The first line is an integer n, indicating the length of sequence a;
The second line should contain n space-seprated integers  a1,a2,...,an(a1a2...an) . These are numbers in sequence a.
It's guaranteed that there is only one solution for each case.
 

Sample Input
  
  
6 2 2 2 4 4 4 21 1 2 3 3 4 4 5 5 5 6 6 6 7 7 7 8 8 9 9 10 11
 

Sample Output
  
  
3 2 2 2 6 1 2 3 4 5 6
 

Source
 

题意:
有n个数a,可以两两组合成n(n-1)/2个数b。把它们混成一个数组,让你求出原n个数a。

POINT:
排个序,第一小和第二小肯定都是a数组里的。开一个map记录当前可以确定的b数组里的数。
一开始map里只有a[1]+a[2]。
从3-n开始找,若map里有,则是b数组,更新map。若没有,即是a数组里的,并且把和之前a数组里的数组成的数b更新在map里。

#include <iostream>
#include <string.h>
#include <vector>
#include <algorithm>
#include <map>
#include <stdio.h>
using namespace std;
#define  LL long long
const int N = 125250+8;
map<int,int> m;
vector<int> a;
int z[N];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        m.clear();
        a.clear();
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&z[i]);
        }
        sort(z+1,z+1+n);
        a.push_back(z[1]);
        a.push_back(z[2]);
        m[z[1]+z[2]]++;
        for(int i=3;i<=n;i++)
        {
            if(m[z[i]]>0)
            {
                m[z[i]]--;
                continue;
            }
            else
            {
                a.push_back(z[i]);
                for(int j=0;j<a.size()-1;j++)
                {
                    m[a[j]+z[i]]++;
                }
            }
        }
        sort(a.begin(),a.end());
        printf("%d\n",a.size());
        for(int i=0;i<a.size();i++)
        {
            if(i) printf(" ");
            printf("%d",a[i]);
        }
        printf("\n");
    }
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值