HDU 1757 A Simple Math Problem(构造矩阵)

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5125    Accepted Submission(s): 3103


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 

Output
For each case, output f(k) % m in one line.
 

Sample Input
  
  
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 

Sample Output
  
  
45 104
 

Author
linle
 

Source
 

POINT:

构造两个矩阵



#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;
#define  LL long long
const int N = 10;
int p;
struct mx
{
    int a[N+1][N+1];
};
mx cheng(mx a,mx b)
{
    mx ans;
    for(int i=1;i<=N;i++)
    {
        for(int j=1;j<=N;j++)
        {
            ans.a[i][j]=0;
            for(int k=1;k<=N;k++)
            {
                (ans.a[i][j]+=a.a[i][k]*b.a[k][j])%=p;
            }
        }
    }
    return ans;
}
mx qkm(mx base,int mi)
{
    mx ans;
    for(int i=1;i<=N;i++)
    {
        for(int j=1;j<=N;j++)
        {
            ans.a[i][j]=i==j;
        }
    }
    while(mi)
    {
        if(mi&1) ans=cheng(ans,base);
        base=cheng(base,base);
        mi>>=1;
    }
    return ans;
}
int main()
{
    int k,m;
    int a[10];
    int f[10];
    while(~scanf("%d %d",&k,&m))
    {
        p=m;
        for(int i=0;i<=9;i++)
        {
            scanf("%d",&a[i]);
            f[i]=i;
        }
        if(k<=9)
        {
            printf("%d\n",f[k]%m);
        }
        else
        {
            mx base;
            for(int i=1;i<=10;i++)
            {
                base.a[1][i]=a[i-1];
            }
            for(int i=2;i<=10;i++)
            {
                for(int j=1;j<=10;j++)
                {
                    if(j==i-1)
                    {
                        base.a[i][j]=1;
                    }
                    else base.a[i][j]=0;
                }
            }
            base=qkm(base,k-9);
            int ans=0;
            for(int k=1;k<=10;k++)
            {
                (ans+=base.a[1][k]*f[10-k])%=p;
            }
            printf("%d\n",ans);
        }
        
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值