HDU1757 矩阵快速幂


/***************************8
构造矩阵[a0 a1 a2 a3 a4 ... a9]         [ f(x-1) ]            [f(x)]
               1  0  ..                0
               0  1                            *        .        =            .
               ...                                                              .
               0 0   . ....          1 0]              .                     .
                                                       f(x-10)            f(x-9)

然后矩阵快速幂,
***************************/

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2160    Accepted Submission(s): 1246


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 

Output
For each case, output f(k) % m in one line.
 

Sample Input
  
  
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 

Sample Output
  
  
45 104
# include<iostream>

using namespace std;

int m;

class Matrix{
public:
      int row;
      int col;
      int ** element;
      Matrix();
      ~Matrix();
      Matrix(const int , const int);
      Matrix(const Matrix &);
      Matrix operator = (const Matrix &);
      Matrix operator * (const Matrix &);
      void setMatrix();
      void print()
      {
          for(int i=0; i<row; i++)
          {
              for(int j=0; j<col; j++)
                cout<<element[i][j]<<" ";
              cout<<endl;
          }
      }
      Matrix quickpow(int n)
      {
          Matrix result(row, col);
          Matrix a(*this);
          for(int i=0; i<row; i++)
            result.element[i][i]=1;
          while(n)
          {
              if(n&1)
              result = a*result;
              n=n>>1;
              a=a*a;
          }
          return result;
      }
};

Matrix::Matrix()
{
    row=col=0;
    element=NULL;
}
Matrix::~Matrix()
{
    for(int i=0; i<row; i++)
        delete []element[i];
      delete []element;
}

Matrix::Matrix(const int m_row, const int m_col)
{
    row = m_row;
    col = m_col;
    element = new int *[row];
    for(int i=0; i<row; i++)
        element[i] = new int[col];
    for(int i=0; i<row; i++)
        for(int j=0; j<col; j++)
        element[i][j]=0;
}

Matrix::Matrix(const Matrix & temp)
{
    row = temp.row;
    col = temp.col;
    element = new int *[row];
    for(int i=0; i<row; i++)
        element[i] = new int[col];
    for(int i=0; i<row; i++)
        for(int j=0; j<col; j++)
        element[i][j]=temp.element[i][j];
}

Matrix Matrix::operator =(const Matrix & right)
{
    for(int i=0; i<row; i++)
      delete []element[i];
    delete []element;
    row = right.row;
    col = right.col;
    element = new int *[row];
    for(int i=0; i<row; i++)
        element[i] = new int[col];
    for(int i=0; i<row; i++)
        for(int j=0; j<col; j++)
        element[i][j]=right.element[i][j];
    return *this;
}

Matrix Matrix::operator *(const Matrix & right)
{
    Matrix result(row, right.col);
    for(int i=0; i<row; i++)
        for(int j=0; j<right.col; j++)
        {
            result.element[i][j]=0;
            for(int k=0; k<col; k++)
                {
                    result.element[i][j]+=(element[i][k]*right.element[k][j])%m;
                    result.element[i][j]%=m;
                }
        }
    return result;
}

int main()
{
    int k;
    int a[10];
    while(cin>>k>>m)
    {
        for(int i=0; i<10; i++)
            cin>>a[i];
        if(k<10)cout<<k%m<<endl;
        else
        {
            Matrix b(10, 10);
            for(int i=0; i<10; i++)
                b.element[0][i]=a[i];
            for(int i=1; i<10; i++)
                b.element[i][i-1]=1;
            b=b.quickpow(k-9);
            int ans=0;
            for(int i=0; i<10; i++)
               {
                 ans+=(b.element[0][i]*(9-i))%m;
                 ans%=m;
               }
            cout<<ans<<endl;
        }
    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值