HDU 1003 Max Sum && HDU 1081 To The Max 一维子串最大和& 二维矩阵最大和

24 篇文章 0 订阅

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 253528    Accepted Submission(s): 60167


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L
 

题意:
一维最大连续子串和。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
const int N = 100000+4;
const int inf=0x3f3f3f3f;
int a[N];

int main()
{
    int T;
    scanf("%d",&T);
    int o=0;
    while(T--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        int now=0;
        int ans=-inf;
        int l,r,len = 0;
        for(int i=1;i<=n;i++)
        {
            if(now<0) now=0,len=0;
            now+=a[i];len++;
            if(ans<now)
            {
                ans=now;
                r=i;
                l=i-len+1;
            }
            
        }
        printf("Case %d:\n",++o);
        printf("%d %d %d\n",ans,l,r);
        if(T!=0) printf("\n");

    }
}


To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13433    Accepted Submission(s): 6408


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
    
    
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 

Sample Output
    
    
15
 

Source
 

题意:
二维的。
POINT:

每一行来一个sum前缀和。遍历横向的长度 ,从1到n,降成一维。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
const int N = 100000+4;
const int inf=0x3f3f3f3f;
int a[N];
int mp[111][111];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(mp,0,sizeof mp);
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&mp[i][j]);
            }
            for(int j=1;j<=n;j++)
            {
                mp[i][j]=mp[i][j-1]+mp[i][j];
            }
        }
        int ans=-inf;
        for(int k=1;k<=n;k++)
        {
            for(int j=1;j<=n-k+1;j++)
            {
                int now=0;
                for(int i=1;i<=n;i++)
                {
                    if(now<0) now=0;
                    now+=mp[i][j+k-1]-mp[i][j-1];
                    if(ans<now)
                    {
                        ans=now;
                    }
                }
            }
        }
        printf("%d\n",ans);
        
    }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值